4

Recently switched to Ubuntu 17.10 and saw the 'Software Updater' behaving strangely, different from earlier versions. Now when there are updates, in addition to showing me the 'pop up', Ubuntu has already downloaded everything in the background. But my update settings only instructs ubuntu to notify of updates, not to download.

Why this new type of behavior? Any additional settings somewhere else?

Software Updater Screenshot:

Software Updater Settings Screenshot:

  • 1
    Unattended upgrades also downloads security updates. See This Question – stumblebee Mar 30 '18 at 18:17
  • @stumblebee I tried disabling it with dpkg and then answering 'no': sudo dpkg-reconfigure unattended-upgrades But ubuntu has again auto-downloaded updates. I guess i will now try disabling it with: systemctl disable unattended-upgrades.service Will this disable the auto update check completely? – Mithun Apr 4 '18 at 4:23
  • Just reconfiguring unattended upgrades should have been sufficient. Try changing "Automatically check for updates" to "Never" in "Software & Updates". I don't run my system this way so I am not certain why it would still download when you instructed otherwise. – stumblebee Apr 4 '18 at 4:42
1

Quick answer:

Set "Automatically check for updates" to "Never", & then manually update.

Why:

The standard Software & Updates GUI is based off of the unattended-upgrades package, which auto-downloads security updates when it checks for all upgrades.

From the Ubuntu Automatic Updates page:

The unattended-upgrades package can be used to automatically install updated packages, and can be configured to update all packages or just install security updates.

As XModulo explains:

On Ubuntu, automatic updates are managed by a package called unattended-upgrades which is installed by default. This package downloads and installs security updates automatically. Optionally, it can also auto-upgrade packages available from other configured APT sources (such as "updates", "proposed" "backports").

Xmodulo goes on to explain that the only way to turn off the automatic security update downloads is to change the "Automatically check for updates" setting to "Never". Somewhat counterintuitive, and not a great solution, but necessary if you need to preserve bandwidth, etc.

Manually Updating:

Manually updating is fairly straightforward from Synaptic (which may need to be installed), or from a command line:

sudo apt-get update
sudo apt-get upgrade

Of course, you could setup a reminder to manually update, or other creative bash, etc workarounds if you want some vestige of 'automatic' update.

  • 2
    Thanks for the explanation. I have now switched to Ubuntu 18.04 and this bug is still there, same as in 17.10 - The updates are getting auto-downloaded even though my setting is only to check for updates. I guess now the only solution is to turn it off completely. Sad to see Ubuntu slowly going the way of Windows-10. – Mithun May 16 '18 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.