0

I tried installing some software but failed and I received this error message. Now I would like to remove it and try reinstalling. I heard that there is a command called "clean" that accomplishes this but want to make sure I'm doing it correctly.

lorax@lorax-Inspiron-570:~/ Downloads$ sudo apt-get install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-qgis : Depends: python-qgis-common (= 1:3.0.0+24xenial-ubuntugis) but it is not going to be installed
               Depends: libqgispython3.0.0 but it is not going to be installed
               Depends: libqgis-analysis3.0.0 but it is not going to be installed
               Depends: libqgis-core3.0.0 but it is not going to be installed
               Depends: libqgis-gui3.0.0 but it is not going to be installed
               Depends: libqgis-server3.0.0 but it is not going to be installed
 qgis : Depends: gdal-abi-2-2-2 but it is not installable
        Depends: libqgis-analysis3.0.0 but it is not going to be installed
        Depends: libqgis-app3.0.0 but it is not going to be installed
        Depends: libqgis-core3.0.0 but it is not going to be installed
        Depends: libqgis-gui3.0.0 but it is not going to be installed
        Depends: qgis-providers (= 1:3.0.0+24xenial-ubuntugis) but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:3.0.0+24xenial-ubuntugis) but it is not going to be installed
                     Depends: libqgis-app3.0.0 but it is not going to be installed
                     Depends: libqgis-core3.0.0 but it is not going to be installed
                     Depends: libqgis-gui3.0.0 but it is not going to be installed
                     Depends: libqgisgrass7-3.0.0 but it is not going to be installed
                     Depends: grass740 but it is not installable
E: Unable to correct problems, you have held broken packages.
lorax@lorax-Inspiron-570:~/ Downloads$

Then I ran:

 lorax@lorax-Inspiron-570:~$ apt policy qgis python-qgis qgis-plugin-grass python-qgis-common gda-abi-2-2-2 qgis-providers qgis-provider-grass grass740
qgis:

  Installed: (none)
  Candidate: 1:3.0.1+24xenial-ubuntugis
  Version table:
     1:3.0.1+24xenial-ubuntugis 500
        500 https://qgis.org/ubuntugis xenial/main amd64 Packages
     2.14.11+dfsg-1~xenial4 500
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main amd64 Packages
     2.8.6+dfsg-1build1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
python-qgis:
  Installed: (none)
  Candidate: 1:3.0.1+24xenial-ubuntugis
  Version table:
     1:3.0.1+24xenial-ubuntugis 500
        500 https://qgis.org/ubuntugis xenial/main amd64 Packages
     2.14.11+dfsg-1~xenial4 500
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main amd64 Packages
     2.8.6+dfsg-1build1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
qgis-plugin-grass:
  Installed: (none)
  Candidate: 1:3.0.1+24xenial-ubuntugis
  Version table:
     1:3.0.1+24xenial-ubuntugis 500
        500 https://qgis.org/ubuntugis xenial/main amd64 Packages
     2.14.11+dfsg-1~xenial4 500
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main amd64 Packages
python-qgis-common:
  Installed: (none)
  Candidate: 1:3.0.1+24xenial-ubuntugis
  Version table:
     1:3.0.1+24xenial-ubuntugis 500
        500 https://qgis.org/ubuntugis xenial/main amd64 Packages
        500 https://qgis.org/ubuntugis xenial/main i386 Packages
     2.14.11+dfsg-1~xenial4 500
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main i386 Packages
     2.14.1+dfsg-3~xenial0 500
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main i386 Packages
     2.8.6+dfsg-1build1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
qgis-providers:
  Installed: (none)
  Candidate: 1:3.0.1+24xenial-ubuntugis
  Version table:
     1:3.0.1+24xenial-ubuntugis 500
        500 https://qgis.org/ubuntugis xenial/main amd64 Packages
     2.14.11+dfsg-1~xenial4 500
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main amd64 Packages
     2.8.6+dfsg-1build1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
qgis-provider-grass:
  Installed: (none)
  Candidate: 1:3.0.1+24xenial-ubuntugis
  Version table:
     1:3.0.1+24xenial-ubuntugis 500
        500 https://qgis.org/ubuntugis xenial/main amd64 Packages
     2.14.11+dfsg-1~xenial4 500
        500 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial/main amd64 Packages
     2.8.6+dfsg-1build1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
grass740:
  Installed: (none)
  Candidate: (none)
  Version table:
N: Unable to locate package gda-abi-2-2-2i

marked as duplicate by karel, Eric Carvalho, Charles Green, Elder Geek, waltinator Apr 1 '18 at 14:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • None of the packages you tried to install with the command you showed did get installed so far. The process failed before beginning the actual installation while checking for dependencies. What you need to do is to find out why there are dependency problems and fix them, probably you have some third party repositories enabled which provide incompatible package versions. Please edit your question and add the output of apt policy qgis python-qgis qgis-plugin-grass python-qgis-common gda-abi-2-2-2 qgis-providers qgis-provider-grass grass740, then notify me with a comment. Thanks. – Byte Commander Mar 30 '18 at 12:53
  • Edited my question and added the output as you suggested. – lorax Mar 30 '18 at 13:10
  • I need the full output, not just a part. Anyway, seems like you added both a PPA and the external qgis.org repository, so now at least the qgis packages is available from 3 different servers, in 3 different versions. apt will always pick the one with the highest version number when deciding which version to install. However, the 3.0 version seems to have dependencies which are not provided by that qgis.org repository, and neither by any other of your sources, at least not in the correct version. Do you need qgis 3.0, or is 2.8 (or maybe 2.14) enough? Also, please add the remaining output. – Byte Commander Mar 30 '18 at 13:19
  • I am new to this site, it won't allow me to post the entire output. It says that I need a reputation of 10 to post a file with more than 8 links. I can settle for QGIS 2.18 and QGIS 2.14 would be enough too. – lorax Mar 30 '18 at 13:33
  • 3