1

I'm using Ubuntu 16.04. I needed ROS Kinetic but I had ROS Lunar, so I tried to install it but I had different errors. So, following some internet advices, I uninstalled some packages and now I have a lot of problems. First, I don't have Software & Updates anymore and I can't install it using

sudo apt-get install software-properties-gtk

When I try to install anything, this is the output of the terminal:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 account-plugin-facebook : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or
                                    ubuntu-system-settings-online-accounts but it is not going to be installed
 account-plugin-flickr : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or
                                  ubuntu-system-settings-online-accounts but it is not going to be installed
 account-plugin-google : Depends: libaccount-plugin-google but it is not going to be installed or
                                  ubuntu-system-settings-online-accounts but it is not going to be installed
 adduser : Depends: perl-base (>= 5.6.0) but it is not going to be installed
           Depends: passwd (>= 1:4.1.5.1-1.1ubuntu6) but it is not going to be installed
 adwaita-icon-theme : Depends: libgtk-3-bin but it is not going to be installed
                      Depends: librsvg2-common but it is not going to be installed
 alsa-base : Depends: kmod (>= 17-1) but it is not going to be installed
             Depends: udev but it is not going to be installed
             Recommends: alsa-utils but it is not going to be installed
 apparmor:amd64 : Depends: python3:any
 apt : Depends: gpgv but it is not going to be installed or
                gpgv2 but it is not going to be installed
       Depends: gnupg but it is not going to be installed or
                gnupg2 but it is not going to be installed
 arduino : Depends: default-jre but it is not going to be installed or
                    java6-runtime
           Depends: librxtx-java (>= 2.2pre2-3) but it is not going to be installed
           Recommends: policykit-1 but it is not going to be installed
 arduino-core : Depends: gcc-avr (>= 4.7.0) but it is not going to be installed
                Depends: avrdude but it is not going to be installed
                Depends: gcc but it is not going to be installed
 aspell-en : Depends: aspell (>= 0.60.3-2) but it is not going to be installed
 avr-libc : Depends: gcc-avr (>= 1:4.9.2+Atmel3.5.0) but it is not going to be installed
            Depends: binutils-avr (>= 2.25+Atmel3.5.0) but it is not going to be installed
 bash-completion : PreDepends: dpkg (>= 1.15.7.2~) but it is not going to be installed
                   Depends: bash (>= 3.2) but it is not going to be installed
 bzip2-doc : Depends: dpkg (>= 1.15.4) but it is not going to be installed or
                      install-info but it is not going to be installed
 bzr : Depends: python-bzrlib (<= 2.7.0-2ubuntu3.1.1~) but it is not going to be installed
       Depends: python-bzrlib (>= 2.7.0-2ubuntu3.1) but it is not going to be installed
       Depends: python:any
       Recommends: python-gpgme but it is not going to be installed
 ca-certificates : Depends: openssl (>= 1.0.0) but it is not going to be installed
 ca-certificates-java : Depends: openjdk-8-jre-headless but it is not going to be installed or
                                 java7-runtime-headless
                        Depends: libnss3 (>= 3.12.9+ckbi-1.82-0ubuntu3~) but it is not going to be installed
 checkbox-converged : Depends: plainbox-provider-checkbox but it is not going to be installed
                      Depends: python3 but it is not going to be installed
                      Depends: qml-module-qtquick-layouts but it is not going to be installed
                      Depends: qmlscene but it is not going to be installed
                      Depends: qtdeclarative5-dev-tools but it is not going to be installed
                      Depends: qtdeclarative5-test-plugin but it is not going to be installed
                      Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin
 cheese:amd64 : Depends: gnome-video-effects:amd64 but it is not installable
 cheese-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                          gsettings-backend
 cm-super : Depends: dpkg (>= 1.14.18) but it is not going to be installed
            Depends: pfb2t1c2pfb but it is not going to be installed
 cm-super-minimal : Depends: dpkg (>= 1.14.18) but it is not going to be installed
 colord:amd64 : Depends: colord-data:amd64 but it is not installable
 compiz : Depends: compiz-core (>= 1:0.9.12.3+16.04.20180221-0ubuntu1) but it is not going to be installed
          Depends: compiz-plugins-default (>= 1:0.9.12.3+16.04.20180221-0ubuntu1) but it is not going to be installed
          Depends: compiz-gnome but it is not going to be installed
 compiz-gnome:amd64 : Depends: gnome-settings-daemon-schemas:amd64 (>= 3.4.2-0ubuntu9) but it is not installable
 console-setup-linux : Depends: kbd (>= 1.15-1ubuntu3) but it is not going to be installed
 context : Depends: texlive-binaries (>= 2014.20140512.33982) but it is not going to be installed
           Recommends: fonts-freefont but it is not installable
 context-modules : Depends: dpkg (>= 1.14.18) but it is not going to be installed
 debconf : PreDepends: perl-base (>= 5.6.1-4) but it is not going to be installed
           Recommends: apt-utils (>= 0.5.1) but it is not going to be installed
 debconf-i18n : Depends: liblocale-gettext-perl but it is not going to be installed
                Depends: libtext-iconv-perl but it is not going to be installed
                Depends: libtext-charwidth-perl but it is not going to be installed
 debhelper : Depends: perl but it is not going to be installed
             Depends: file (>= 3.23) but it is not going to be installed
             Depends: dpkg (>= 1.16.2) but it is not going to be installed
             Depends: binutils but it is not going to be installed
             Depends: man-db (>= 2.5.1-1) but it is not going to be installed
 dh-python : Depends: python3:any (>= 3.3.2-2~)
 dh-strip-nondeterminism : Depends: perl but it is not going to be installed
 dictionaries-common : Depends: libtext-iconv-perl but it is not going to be installed
 doc-base : Depends: libuuid-perl but it is not going to be installed
 dpkg-dev : Depends: bzip2 but it is not going to be installed
            Depends: xz-utils but it is not going to be installed
            Depends: patch (>= 2.7) but it is not going to be installed
            Depends: make
            Depends: binutils but it is not going to be installed
            Depends: base-files (>= 5.0.0) but it is not going to be installed
            Recommends: gcc but it is not going to be installed or
                        c-compiler
            Recommends: build-essential but it is not going to be installed
            Recommends: fakeroot
            Recommends: gnupg but it is not going to be installed or
                        gnupg2 but it is not going to be installed
            Recommends: gpgv but it is not going to be installed or
                        gpgv2 but it is not going to be installed
 evince:amd64 : Depends: evince-common:amd64 (>= 3.18) but it is not installable
                Depends: evince-common:amd64 (< 3.19) but it is not installable
 evince-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                          gsettings-backend
 evolution-data-server:amd64 : Depends: evolution-data-server-common:amd64 (= 3.18.5-1ubuntu1) but it is not installable
 evolution-data-server-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                                         gsettings-backend
 evolution-data-server-online-accounts:amd64 : Depends: evolution-data-server-common:amd64 (= 3.18.5-1ubuntu1) but it is not installable
 feynmf : Depends: dpkg (>= 1.14.18) but it is not going to be installed
          Depends: perl but it is not going to be installed
 fonts-horai-umefont : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-ipaexfont-gothic : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-ipaexfont-mincho : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-ipafont-gothic : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-ipafont-mincho : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-kacst : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-kacst-one : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-lato : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-nanum : PreDepends: dpkg (>= 1.15.7.2) but it is not going to be installed
 fonts-sil-abyssinica : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-sil-gentiumplus : Depends: fontconfig but it is not going to be installed
 fonts-takao-pgothic : PreDepends: dpkg (>= 1.15.6~) but it is not going to be installed
 fonts-unfonts-core : PreDepends: dpkg (>= 1.15.7.2) but it is not going to be installed
 foomatic-db-compressed-ppds : Depends: python3 but it is not going to be installed
                               Depends: xz-utils but it is not going to be installed
                               Recommends: cups-filters (>= 1.0.42) but it is not going to be installed or
                                           foomatic-filters (>= 4.0)
                               Recommends: ghostscript but it is not going to be installed
                               Recommends: cups but it is not going to be installed
                               Recommends: cups-client but it is not going to be installed
 fragmaster : Depends: texlive-base-bin
              Depends: ghostscript but it is not going to be installed
              Depends: perl but it is not going to be installed
 friendly-recovery : Depends: upstart but it is not going to be installed or
                              systemd-sysv but it is not going to be installed
                     Depends: whiptail but it is not going to be installed
                     Recommends: gettext-base but it is not going to be installed
                     Recommends: update-manager-core (>= 0.90.0) but it is not going to be installed
 gconf2:amd64 : Depends: python3:any
 gedit:amd64 : Depends: python3:any (>= 3.3.2-2~)
               Depends: gedit-common:amd64 (>= 3.18) but it is not installable
               Depends: gedit-common:amd64 (< 3.19) but it is not installable
 gedit-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                         gsettings-backend
                Recommends: gedit but it is not going to be installed
 ghostscript:amd64 : Depends: gsfonts:amd64 (>= 6.0-1) but it is not installable
 gir1.2-ibus-1.0:amd64 : Depends: python3:any (>= 3.3.2-2~)
 git:amd64 : Depends: liberror-perl:amd64 but it is not installable
 git-core : Depends: git (> 1:1.7.0.2) but it is not going to be installed
 gnome-exe-thumbnailer : Depends: icoutils but it is not going to be installed
                         Depends: imagemagick
                         Depends: libglib2.0-bin but it is not going to be installed
                         Recommends: msitools but it is not installable
 gnome-menus:amd64 : Depends: python3:any (>= 3.1~)
 gnome-orca : Depends: dconf-gsettings-backend but it is not going to be installed or
                       gsettings-backend
              Depends: python3:any (>= 3.3.2-2~)
              Depends: gir1.2-glib-2.0 but it is not going to be installed
              Depends: gir1.2-gtk-3.0 (>= 3.6.2) but it is not going to be installed
              Depends: gir1.2-pango-1.0 but it is not going to be installed
              Depends: gir1.2-wnck-3.0 but it is not going to be installed
              Depends: python3-brlapi (>= 0.5.1) but it is not going to be installed
              Depends: python3-cairo but it is not going to be installed
              Depends: python3-gi (>= 3.10) but it is not going to be installed
              Depends: speech-dispatcher (>= 0.8) but it is not going to be installed
              Recommends: xbrlapi but it is not going to be installed
              Recommends: libgail-common but it is not going to be installed
 gnome-power-manager:amd64 : Depends: gnome-settings-daemon-schemas:amd64 (>= 3.2) but it is not installable
 gnome-settings-daemon-schemas : Depends: dconf-gsettings-backend but it is not going to be installed or
                                          gsettings-backend
 gnome-terminal:amd64 : Depends: gnome-terminal-data:amd64 (>= 3.18) but it is not installable
                        Depends: gnome-terminal-data:amd64 (< 3.19) but it is not installable
 gnome-user-guide : Depends: yelp (>= 3) but it is not going to be installed
 gnome-video-effects : Depends: gstreamer1.0-plugins-good but it is not going to be installed
 gsettings-desktop-schemas : Depends: dconf-gsettings-backend but it is not going to be installed or
                                      gsettings-backend
 gsettings-ubuntu-schemas : Depends: dconf-gsettings-backend but it is not going to be installed or
                                     gsettings-backend
 gvfs-common : Depends: desktop-file-utils but it is not going to be installed
               Recommends: gvfs but it is not going to be installed
 hardening-includes : Depends: perl but it is not going to be installed
                      Depends: make
                      Depends: binutils but it is not going to be installed
 hplip-data : Depends: xz-utils but it is not going to be installed
              Depends: python3:any (>= 3.3.2-2~)
 hwdata : Depends: usbutils but it is not going to be installed
          Depends: pciutils but it is not going to be installed
 ibus:amd64 : Depends: python3:any (>= 3.3.2-2~)
              Recommends: im-config:amd64 but it is not installable
 ibus-table : Depends: ibus (>= 1.5.0) but it is not going to be installed
              Depends: python3:any (>= 3.3.2-2~)
 icoutils:amd64 : Depends: libwww-perl:amd64 but it is not installable
 im-config : Depends: gettext-base but it is not going to be installed
             Depends: zenity but it is not going to be installed or
                      kde-baseapps-bin but it is not going to be installed or
                      whiptail but it is not going to be installed
             Recommends: whiptail but it is not going to be installed
 imagemagick-common : PreDepends: dpkg (>= 1.15.7.2) but it is not going to be installed
 indicator-keyboard:amd64 : Depends: libgnomekbd-common:amd64 but it is not installable
 indicator-session:amd64 : Depends: gnome-settings-daemon-schemas:amd64 but it is not installable
 init-system-helpers : Depends: perl-base (>= 5.20.1-3) but it is not going to be installed
 initramfs-tools-core : Depends: initramfs-tools-bin (= 0.122ubuntu8.10) but it is not going to be installed
                        Depends: busybox-initramfs (>= 1:1.13.3-1ubuntu5) but it is not going to be installed
                        Depends: klibc-utils (>= 2.0.4-7~) but it is not going to be installed
                        Depends: cpio but it is not going to be installed
                        Depends: kmod but it is not going to be installed or
                                 module-init-tools but it is not going to be installed
                        Depends: udev but it is not going to be installed
 intltool-debian : Depends: perl but it is not going to be installed
                   Depends: gettext but it is not going to be installed
 ipython : Depends: python (>= 2.7) but it is not going to be installed
           Depends: python (< 2.8) but it is not going to be installed
 ipython-notebook : Depends: python-tornado (>= 3.1.0) but it is not going to be installed
                    Depends: python-zmq (>= 2.1.11) but it is not going to be installed
                    Depends: python (>= 2.7) but it is not going to be installed
                    Depends: python (< 2.8) but it is not going to be installed
 isympy : Depends: python:any or
                   python:any
 kbd:amd64 : Depends: console-setup:amd64 but it is not installable or
                      console-setup-mini:amd64 but it is not installable
 keyboard-configuration : Depends: liblocale-gettext-perl but it is not going to be installed
                          Depends: initscripts but it is not going to be installed
 kicad:amd64 : Depends: kicad-common:amd64 (>= 4.0.2+dfsg1-4) but it is not installable
 language-pack-en : PreDepends: dpkg (>= 1.16.1) but it is not going to be installed
 language-pack-en-base : PreDepends: dpkg (>= 1.16.1) but it is not going to be installed
 language-pack-gnome-en : PreDepends: dpkg (>= 1.16.1) but it is not going to be installed
 language-pack-gnome-en-base : PreDepends: dpkg (>= 1.16.1) but it is not going to be installed
 latex-cjk-all : Depends: latex-cjk-common (>= 4.8.4+git20150701-1) but it is not going to be installed
                 Depends: latex-cjk-chinese (>= 4.8.4+git20150701-1) but it is not going to be installed
                 Depends: latex-cjk-japanese (>= 4.8.4+git20150701-1) but it is not going to be installed
 latex-cjk-chinese-arphic-bkai00mp : Depends: dpkg (>= 1.14.18) but it is not going to be installed
 latex-cjk-chinese-arphic-bsmi00lp : Depends: dpkg (>= 1.14.18) but it is not going to be installed
 latex-cjk-chinese-arphic-gbsn00lp : Depends: dpkg (>= 1.14.18) but it is not going to be installed
 latex-cjk-chinese-arphic-gkai00mp : Depends: dpkg (>= 1.14.18) but it is not going to be installed
 latex-cjk-common:amd64 : Depends: emacsen-common:amd64 (>= 2.0.8) but it is not installable
 latex-cjk-japanese-wadalab : Depends: dpkg (>= 1.14.18) but it is not going to be installed
 latex-cjk-korean : Depends: latex-cjk-common (>= 4.8.4+git20150701-1) but it is not going to be installed
 latex-cjk-thai : Depends: latex-cjk-common (>= 4.8.4+git20150701-1) but it is not going to be installed
 latexdiff : Depends: perl but it is not going to be installed
 latexmk : Depends: perl but it is not going to be installed
           Recommends: xpdf-reader but it is not installable or
                       pdf-viewer
           Recommends: gv but it is not going to be installed or
                       postscript-viewer
 lcdf-typetools:amd64 : Depends: aglfn:amd64 but it is not installable
 liba11y-profile-manager-data : Depends: dconf-gsettings-backend but it is not going to be installed or
                                         gsettings-backend
 libalgorithm-diff-perl : Depends: perl but it is not going to be installed
                          Recommends: libalgorithm-diff-xs-perl but it is not going to be installed
 libalgorithm-diff-xs-perl:amd64 : Depends: libalgorithm-diff-perl:amd64 but it is not installable
 libalgorithm-merge-perl : Depends: perl but it is not going to be installed
 libarchive-zip-perl : Depends: perl but it is not going to be installed
 libasyncns0 : PreDepends: multiarch-support but it is not going to be installed
 libauthen-sasl-perl : Depends: perl but it is not going to be installed
 libavcodec-extra : Depends: libavcodec-ffmpeg-extra56 but it is not going to be installed
 libcapi20-3 : PreDepends: multiarch-support but it is not going to be installed
 libcgi-fast-perl : Depends: perl but it is not going to be installed
                    Depends: libfcgi-perl but it is not going to be installed
 libcgi-pm-perl : Depends: perl but it is not going to be installed
                  Depends: libhtml-parser-perl but it is not going to be installed
 libclass-accessor-perl : Depends: perl but it is not going to be installed
                          Depends: libsub-name-perl but it is not going to be installed
 libclass-data-inheritable-perl : Depends: perl but it is not going to be installed
 libclass-method-modifiers-perl : Depends: perl but it is not going to be installed
 libdata-random-perl : Depends: perl but it is not going to be installed
                       Recommends: libgd-perl but it is not going to be installed
 libdigest-hmac-perl : Depends: perl but it is not going to be installed
 libdpkg-perl : Depends: dpkg (>= 1.16.3) but it is not going to be installed
                Depends: perl but it is not going to be installed
                Recommends: libfile-fcntllock-perl but it is not going to be installed
                Recommends: bzip2 but it is not going to be installed
                Recommends: xz-utils but it is not going to be installed
 libedataserver-1.2-21:amd64 : Depends: evolution-data-server-common:amd64 (>= 3.18) but it is not installable
 libedataserverui-1.2-1:amd64 : Depends: evolution-data-server-common:amd64 (>= 3.18) but it is not installable
 libemail-valid-perl : Depends: perl but it is not going to be installed
                       Depends: libnet-dns-perl but it is not going to be installed
 libencode-locale-perl : Depends: perl but it is not going to be installed
 liberror-perl : Depends: perl but it is not going to be installed
 libexif12 : PreDepends: multiarch-support but it is not going to be installed
 libexporter-tiny-perl : Depends: perl but it is not going to be installed
 libexttextcat-2.0-0:amd64 : Depends: libexttextcat-data:amd64 (= 3.4.4-1ubuntu3) but it is not installable
 libextutils-depends-perl : Depends: perl but it is not going to be installed
 libextutils-pkgconfig-perl : Depends: perl but it is not going to be installed
                              Depends: pkg-config
 libfile-basedir-perl : Depends: perl but it is not going to be installed
 libfile-copy-recursive-perl : Depends: perl (>= 5.6.0-16) but it is not going to be installed
 libfile-desktopentry-perl : Depends: perl but it is not going to be installed
 libfile-homedir-perl : Depends: perl but it is not going to be installed
 libfile-listing-perl : Depends: perl but it is not going to be installed
 libfile-mimeinfo-perl : Depends: perl but it is not going to be installed
                         Depends: shared-mime-info but it is not going to be installed
 libfile-stripnondeterminism-perl : Depends: perl but it is not going to be installed
 libfile-which-perl : Depends: perl but it is not going to be installed
 libfont-afm-perl : Depends: perl (>= 5.6.0-16) but it is not going to be installed
 libgnome2-common : Depends: gconf2 (>= 2.28.1-2) but it is not going to be installed
 libgnomekbd-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                               gsettings-backend
 libgnomekbd8:amd64 : Depends: libgnomekbd-common:amd64 (>= 3.6.0-1ubuntu2) but it is not installable
 libgoa-1.0-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                              gsettings-backend
 libgoo-canvas-perl:amd64 : Depends: libextutils-depends-perl:amd64 but it is not installable
                            Depends: libextutils-pkgconfig-perl:amd64 but it is not installable
 libgpm2 : PreDepends: multiarch-support but it is not going to be installed
 libgs9:amd64 : Depends: libgs9-common:amd64 (>= 9.18~dfsg~0) but it is not installable
 libgtk-3-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                            gsettings-backend
                   Recommends: libgtk-3-0 but it is not going to be installed
 libgweather-common : Depends: dconf-gsettings-backend but it is not going to be installed or
                               gsettings-backend
 libhtml-form-perl : Depends: perl but it is not going to be installed
                     Depends: libhtml-parser-perl but it is not going to be installed
 libhtml-format-perl : Depends: perl but it is not going to be installed
 libhtml-parser-perl:amd64 : Depends: libhtml-tagset-perl:amd64 but it is not installable
                             Depends: liburi-perl:amd64 but it is not installable
                             Recommends: libhttp-message-perl:amd64 but it is not installable
 libhtml-tagset-perl : Depends: perl (>= 5.6.0-16) but it is not going to be installed
 libhtml-tree-perl : Depends: perl but it is not going to be installed
                     Depends: libhtml-parser-perl but it is not going to be installed
 libhttp-cookies-perl : Depends: perl but it is not going to be installed
 libhttp-daemon-perl : Depends: perl but it is not going to be installed
 libhttp-date-perl : Depends: perl but it is not going to be installed
 libhttp-message-perl : Depends: perl but it is not going to be installed
                        Depends: perl (>= 5.11) but it is not going to be installed or
                                 libio-compress-perl
 libhttp-negotiate-perl : Depends: perl but it is not going to be installed
 libhttp-server-simple-perl : Depends: perl but it is not going to be installed
 libice6 : PreDepends: multiarch-support but it is not going to be installed
 libieee1284-3 : PreDepends: multiarch-support but it is not going to be installed
 libimage-magick-perl : Depends: perl but it is not going to be installed
                        Depends: libimage-magick-q16-perl but it is not going to be installed
 libio-html-perl : Depends: perl but it is not going to be installed
 libio-socket-inet6-perl : Depends: perl but it is not going to be installed
                           Depends: libsocket6-perl but it is not going to be installed

(much more lines of similar things, but the post is longer than 30.000 characters so I cut them off), and the last line is:

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)

If I try

sudo apt-get -f install

The output is the same but at the end it says:

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
1
  • Could you try the following debug commands and upload the output to paste.ubuntu.com . apt-get -s -o Debug::pkgProblemResolver=yes install software-properties-gtk and echo q | aptitude -s install software-properties-gtk . Reference: askubuntu.com/a/708647/26246
    – user.dz
    Apr 2 '18 at 8:25