Complete newbie here. I have installed Ubuntu and love it, but the screen brighness is far too low. I cannot use the computer in the daytime. I have insalled Ubuntu single boot in an intel iMac with rEFInd.

Forgive me if I give too litle information; happy to post outputs of any commands.

Some facts so far:

The slider on “brightness and lock” has no effect at all.

I have tried installing xbacklight and the -in and -dec commands do nothing.

I changed the grub file to say:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=none acpu_osi= " GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=vendor"

I also tried "native" and "video" in this last line. No change.

Then I tried this solution: link

sudo apt install sysfsutils

“ls /sys/class/backlight/” returns "acpi_video0"

I don’t have a folder called /sys/class/brightness.

$ lspci -nnk | grep "VGA" -A2 gives:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] [1002:6741]

Then I tried for i in /sys/class/backlight/*; do echo $i; cat $i/brightness; cat $i/actual_brightness; cat $i/max_brightness; done

and got:

15 15 15

I installed “indicator brightness, which shows values from 1 -15 but has no effect.

I think that what is happening is that the acpi_video0 control is given to a root or BIOS device (maybe EFI partition?)and stuck at 15, which I cannot change.

Any suggestions on what I should do to be able to use Ubuntu is daylight conditions? Much appreciated.

UPDATE: I tried to edit /usr/share/X11/xorg.conf.d/10-radeon.conf the orginal reads:

Section "OutputClass" Identifier "Radeon" MatchDriver "radeon" Driver "radeon" EndSection

I changed it to read:

Section "Device" Identifier "card0" Driver "Radeon" Option "Backlight" "radeon_backlight" BusID "PCI:0:2:0" EndSection

But that dodn't work: the reboot hung on "start user manager for UID 121". So I have edited the file back to the orginal from the live USB.

Any help would be much appreciated!

2 Answers 2


You can change brightness in the System Settings >> Brightness & Lock, or if you are in a laptop you can do it by fn + F8/F9 (differs in device used) if you are on a pc then maybe you can change it directly on the monitor.

  • Thanks, Joshua, but the slider on “brightness and lock” has no effect at all. I'm on an iMac so there are no brightness buttons on the monitor Apr 6, 2018 at 9:08
  • You might want to install third-party apps, try searching google for some. Apr 6, 2018 at 9:28
  • I've tried "brightness Controller" and "indicator Brightness" as apps, and tried xbacklight from the terminal. No effect. Apr 6, 2018 at 9:32

Solved, sort of.

It appears that when installing on a mac, even if you choose the "entire disk" insallation from Ubuntu, mac architecture is left on the machine, including the EFI partition, where OS Recovery lives. This left over stuff is where brightness is controlled from.

So, to solve it, I re-installed MacOS on the machine, then re-installed Ubuntu (17.10 this time) on a new partition. To change brightness, I log in to MacOS to set the maximum brightness, then reboot into Ubuntu. The brightness controls and xbacklight still do not work, but brightness-controller (link here) can adjust the brightness up to the brightness level I was using in MacOS. I think this is because brightness-controller uses xrandr to mimic brightness, rather than actually changing the LCD backlight.

It is still a pain, but at least this way, I can set brightness and use Ubuntu in the daytime. If anyone knows of a better solution, in which I can use the system settings slider to control brightness, that would be great. for now, it is usable though not ideal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .