1

I'm trying to install a dual-boot setup of Ubuntu/Windows 10 on my current Windows laptop

Laptop: Inspiron 5577 (Dell)
OS: Windows 10 64-bit
BIOS: 1.0.5
Processor: Intel i5-7300HQ
RAM: 8192 MB
GPU: Nvidia GeForce GTX 1050
Disk: 256GB SSD

I'm trying to install: ubuntu 16.04.4 LTS

  • My computer is free of viruses.
  • I ran chkdsk on my hard drive. No issues.
  • Shrunk my Windows partition to create 20GB of free space. No issues.
  • Downloaded ubuntu-16.04.4-desktop-amd64.iso.
  • The MD5 hash of the above matches what it should be.
  • Downloaded Rufus, and used it to format my 8GB flash drive and burn the ISO to the flash drive (FAT32, GPT partition scheme for UEFI, block size 4096 bytes, quick format on, create extended labels and files on, quick format on). I also had Rufus check the device for bad blocks, all passes were successful with no errors.
  • More than enough space after formatting the drive and burning the ISO. The flash drive still has at least 5GB of free space, which should be more than enough to boot the live version.
  • On the flash drive, using Cygwin, I ran md5sum -c md5sum.txt | grep -v "OK$. No output, which means everything went as it should.
  • Disabled Windows fast startup from the Control Panel
  • Restarted PC, went to (UEFI) boot manager, disabled Windows Secure Boot.
  • Set a new boot option, designating the media file path as D:\EFI\BOOT\Bootx64.EFI where D: refers to my flash drive. I should mention that D:\EFI\BOOT\grubx64.EFI was also present in this directory, but I wasn't sure which to use here so I just picked one.
  • Saved the above boot settings and tried to boot from the USB. A menu shows up, similar to the following: enter image description here At this point I tried several things:
  • If I tried to select "Install Ubuntu" (which is my eventual goal), I was taken to the ubuntu screen with the five dots, at which point my screen eventually freezes.
  • I tried doing the above after editing the boot options and replacing quiet splash with nomodeset. Trying to boot this way, my screen simply appeared black rather and did nothing. Other options, such as nvidia.modeset=0, acpi = off and no splash didn't help at all.
  • I tried Try Ubuntu Without Installing. Again, black screen. However, if I left the black screen for a while (10 minutes), I would get a message very much like the following: enter image description here

I would really like to get to the bottom of this. It seems I have tried most of what I've managed to find online, but there's always something I might've missed. Based on the details, perhaps someone can point me to the actual solution. It is also possible my hardware just isn't compatible with Ubuntu, although this seems strange, given that Ubuntu has installed successfully on all my previous Windows machines.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.