0

I have recently set-up a dual boot Ubuntu 16.04 / Windows 10 on my laptop SSD. I am mainly using Ubuntu, but for some applications and to avoid file duplicates between the 2 OS I would like to mount the Windows partition at startup.

For this I have been using the graphical "Disks" program and followed the procedure as described here: How to automount my Windows partition at boot?.

After turning off automatic mount options and ticked "Mount at startup", /etc/fstab now contains the line for the partition: /dev/disk/by-uuid/464A34024A33ED75 /mnt/464A34024A33ED75 auto nosuid,nodev,nofail,x-gvfs-show 0 0.

However, after rebooting Ubuntu I cannot access the partition anymore. It simply does not appear neither in /media/, nor in Nautilus. Curiously, if I open "Disks" again, the partition appears as mounted. From there if I dismount/mount the partition, everything works fine again.

Any help would be greatly appreciated, thanks!

  • are you shutting down windows ... are you putting windows into hibernate .. did you shut off hibernate and fast boot ... if not ... windows and any drives associated with windows will be locked and not accessible in Linux. Windows 10 when shutting down does not shut the computer down ... it works like a semi-hibernate for "fast start" the only way to actually have your computer fully reset is to reboot now a days :( but ... you do have to shut down fastboot in the power settings and it would be best to remove hibernate too .. i think then the drive will be unlocked when you shut down windows – John Orion Mar 28 '18 at 15:41
  • I also came across this link which has a command to run that may fix it – John Orion Mar 28 '18 at 15:48
  • Hello John. I've actually just fixed the issue. It was pretty stupid from me. I hadn't noticed the default mounting point changed when I disabled the automatic mount options (i.e. it switched from /media to /mnt). – majpark Mar 28 '18 at 15:53
  • ahh ok :D well at least you got it working for yourself .. thats all that matters :D – John Orion Mar 28 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.