1

After a fresh install of Ubuntu server 16.04.4, the system shuts down fine with sudo poweroff but hangs completely after : sudo reboot, sudo systemctl reboot or sudo shutdown -r now. It doesn't matter if the command is launched via SSH or local session.

I tried to add acpi=force as GRUB option, I tried to disable the swap but nothing worked so far.

Here's the displayed message as a picture. I think it happens too late during the process and isn't logged anywhere :

enter image description here

Possibly relevant lines could be :

systemd-shutdown[11]: failed to finalize DM devices, ignoring
...
general protection fault: 0000 [#11] SMP
...
Code: Bad RIP value.
...

Do you have any idea what the problem is or what a possible fix could be?

1

You appear to experiencing a kernel bug or hardware failure, since you triggered a general protection fault.

This is likely hardware-specific.

I would recommend trying to upgrade to an 18.04 beta, since 18.04 is nearing release, and seeing if the newer kernel fixes it.

Otherwise, consider searching for a kernel bug report about that relates to your hardware. If none is found, considering opening a new kernel bug report about it.

2
  • 1
    I thought about updating to 18.04, yes, and will try it ASAP. I don't think I should try it over SSH though, since I'll have to reboot at least once with the current kernel. It seems weird to me that poweroff works but reboot doesn't. I'll come back to comment. Mar 29 '18 at 17:44
  • 1
    Upgrading to 18.04 solved the reboot problem. Thanks. Apr 3 '18 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.