1

I'm using Ubuntu 16.04.4 and it's running on a VM. The disk that has the origin data has an I/O limit on 1MB/s and disk for cache has no limit. I have followed the guide at fibervillage to create the LVM and succeeded without errors, with the modification to cachemode writeback, and I also did try writethrough just to try.

When the LV is without cache I got the expected behavior with 1MB transfer rate, But when I added the cahepool to the origin LV I do not see any performance enhancement at all. But creating a LV on the same disk were the cache pool is I get way faster transfer rate. I mounted all volumes in /etc/fstab with sync,dirsync options to avoid any other caching.

  • 1
    Maybe you are using kernel version before 4.12? Take a look at this article, performance improves a lot since Linux kernel 4.12. – cyfdecyf Jul 30 '18 at 5:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.