0

I'm having problems with my internet on my Ubuntu 17.10 system. It was working until yesterday. But since today I'm not able to connect to the internet via browser (Firefox and Chrome). I get a DNS_PROBE_FINISHED_BAD_CONFIG error. I tried the following to resolve the problem. I have to admit that I'm not a very experienced Ubuntu user :-)

  • I am able to ping my own DNS (127.0.1.1) --- (64 bytes from...)
  • I am not able to ping an external website (www.google.com) --- (Name or service...)
  • nslookup shows a time out error
  • I changed the DNS to 8.8.8.8, still same error (in resolv.conf and GUI)

I have tried WIFI and wired connection, same result. I tried even to use my phone as a hub but also no impact. The network works because the other computer (WIN) is able to browse the internet.

Do you guys have any advice for me? I don't know what else I can try.

5
  • 1
    Can you: ping -c3 8.8.8.8 ? Welcome to Ask Ubuntu. – chili555 Mar 28 '18 at 16:07
  • yes i can ping that – chrigi Mar 28 '18 at 16:11
  • @chrigi Do you get a response that is not an error message with either dig +short @8.8.8.8 google.com or nslookup google.com 8.8.8.8? – Thomas Ward Mar 28 '18 at 17:03
  • hey thomas, thanks. both ways give me a response without error. – chrigi Mar 28 '18 at 17:08
  • Check the output of nslookup www.google.com to make sure You are indeed using the 8.8.8.8 as dns server. – Michal Przybylowicz Mar 28 '18 at 18:39
1

Please try:

sudo dpkg-reconfigure resolveconf

Say yes to "prepare /etc/resolve.conf for dynamic updates?" and reboot.

2
  • u are awesome :-) that was the solution. i read this before but resolveconf was not installed on my ubunte and since i had no internet i could not download the package. but i downloaded the package resolveconf on another pc and transfered it to my ubuntu and installed it. it did exactly what u said and it works now! genious! thank you – chrigi Mar 28 '18 at 20:51
  • Great news! Glad it's working as expected. I'm sure you will help a few searchers, as well. – chili555 Mar 28 '18 at 20:53
0

The answer above will only work for some (those with reselveconf installed in the first place).

In Ubuntu 17.10 they changed to netplan to manage networks. What you edit and where you edit it has all changed. Through experience I have found all the stuff you used to edit is still there, and editing it can just all further layers of problems. Just do everything you can at the Netplan level, make life easy.

for desktop it is now netplan/networkmanager for server (headerless) it is now netplan/networkd

So basically anything you have edited in the past doesn't really work anymore.

As far as I understand you now edit gui from within the gui (I don't use the gui), if you google ubuntu 18.04 static ip netplan networkd you will probably find what you are looking for. I have only just discovered most of this, and I am still not 100% sure how it all works, which is why I have not told you how I setup my network stuff. Bad advise only makes things worse.

My key info was found here: https://websiteforstudents.com/configure-static-ip-addresses-on-ubuntu-18-04-beta/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.