1

I have a Lenovo Ideapad 710s-14IKB that I would like to dual boot but I'm having trouble. I apologize for the long-winded message but I believe it's all important information to understanding what I've tried and I wouldn't be posting here if I hadn't tried everything I could search for on this site already.

Prior to the issue

The laptop came preinstalled with Windows 10. When I got the machine, I reduced the partition for Windows 10 down to 100GB leaving about 400GB for Ubuntu. I had to change my UEFI settings to disable fast boot, change from RAID to AHCI for the disk controller because I am told Ubuntu does not support RAID. Then I enabled Legacy boot mode. I installed Ubuntu with a boot disk and I have been running Ubuntu ever since.

The problem

I now need to boot back into Windows 10 for a side job. I will be needed to boot into it occasionally so I'd like it to be dual boot and part of the grub menu. I booted into the BIOS setup by using the hardware button on the side of the laptop, enabled RAID mode, rebooted and I got into Windows. I then updated Windows to enable support for AHCI. I went into BIOS, changed back to AHCI mode, rebooted and got the grub menu with now Windows option.

Now I'm trying to get grub to recognize the Windows boot partition with no luck.

Attempt 1

I've tried this according to a tutorial I searched for.

mmachenry@mmachenry-laptop:~$ sudo update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.13.0-37-generic
Found initrd image: /boot/initrd.img-4.13.0-37-generic
Found linux image: /boot/vmlinuz-4.13.0-36-generic
Found initrd image: /boot/initrd.img-4.13.0-36-generic
Found linux image: /boot/vmlinuz-4.13.0-32-generic
Found initrd image: /boot/initrd.img-4.13.0-32-generic
Found linux image: /boot/vmlinuz-4.13.0-21-generic
Found initrd image: /boot/initrd.img-4.13.0-21-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
done 
mmachenry@mmachenry-laptop:~$ sudo grub-install /dev/nvme0n1
Installing for i386-pc platform.
Installation finished. No error reported.

But this doesn't notice any Windows partition.

Attempt 2

I tried boot-repair, installed from another tutorial but it gives me this message when I choose the recommended repair option: "The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example use a live-USB of Boot-Repair-Disk-64bit after making sure your BIO is setup to boot USB in EFI mode." The problem is that when I change the BIOS to enable UEFI mode instead of Legacy mode, the computer is bricked, I get a Lenovo bluescreen saying something went wrong and it gives me several options, on of which is to go back into the BIOS settings where I can change back to legacy mode. So it seems like UEFI mode is not supported for Ubuntu but maybe that's incorrect. Seems odd that boot-repair would demand UEFI mode if Ubuntu doesn't support it. Should I be running in Legacy mode or UEFI mode ideally?

Attempt 3

Finally I tried adding this according to a third tutorial:

mmachenry@mmachenry-laptop:~$ cat /etc/grub.d/40_custom 
#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Windows" {
set root=(hd0,2)
chainloader +1
}

I believe the numbers there should be 0 and 2 because of this:

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      2048     534527    532480   260M EFI System
/dev/nvme0n1p2    534528     567295     32768    16M Microsoft reserved
/dev/nvme0n1p3    567296  217036799 216469504 103.2G Microsoft basic data
/dev/nvme0n1p4 945737728  998166527  52428800    25G Microsoft basic data
/dev/nvme0n1p5 998166528 1000214527   2048000  1000M Windows recovery environment
/dev/nvme0n1p6 217036800  217038847      2048     1M BIOS boot
/dev/nvme0n1p7 217038848  945737727 728698880 347.5G Linux filesystem

But I could be wrong. It basically hasn't done anything even if I set the numbers to different things like 0 3. Windows doesn't even show up on the menu. I ran sudo update-grub and got the same output as above from the last time I ran it and now Windows menu option even appears at boot.

Attempt 4

I change the entry to this

menuentry 'Windows 10' {
    search --fs-uuid --no-floppy --set=root 9CC3-B528
    chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
}

Copying this tutorial and I get the error message "error: invalid signature" from Grub and am presented with the Grub menu once again where I can boot back into Linux.

Closing

Does anyone know how I could get this machine to dual boot? Thank you for your help. I am wondering if there's a mismatch with UEFI mode for Windows and legacy mode for Ubuntu. Do I need installations that match for both?

0
  1. Edit /etc/default/grub with your editor of choice and add GRUB_DISABLE_OS_PROBER=false and save the file
  2. sudo update-grub
  3. Reboot

Hope Windows shall be detected this time.

  • Sadly it has not worked. – mmachenry Mar 28 '18 at 8:02
0

You can also use windows boot manager look for instructions on that I run my dual boot of ubuntu and windows 10 the same way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.