Seriously, sometimes I hate Ubuntu.

I try to get my secondary screen working, but when I enable it I get this error:

The selected configuration for displays could not be applied

required virtual size does not fit available size: requested=(3280, 1050), minimum=(320, 200), maximum=(1680, 1680)

And I know that this question has been asked before, but I still haven't my screen working.

The weird thing is that my secundary screen works till I log in. Before logging in it works fine. But after logging in my screen becomes black.

So I looked around for an answer and I've tried the following things.

  • sudo amdcccle and tried some setting according to multiple displays
  • replaced /etc/X11/xorg.conf
  • sudo aticonfig --initial
  • changed /etc/X11/xorg.conf and changed the 'Subsection display' part.

Only that last method works for me, but only one time. After a reboot this method didn't work out anymore.

Does someone knows an ultimate way to fix this? It really frustrates me.

Thanks in advance.


You will be pleased to hear that 12.04 will have much better support for multiscreens. Using it right now. Piece of cake.

Anyway, the error you get is probably an xrandr error complaining that your virtual display is too small.

If xrandr complains about the desktop not being large enough, put a Virtual info in your xorg.conf file, such as:

Section "Screen"
Identifier "amdcccle-Screen[1]-0"
Device     "amdcccle-Device[1]-0"
DefaultDepth     24
SubSection "Display"
    Viewport   0 0
    Virtual   3360 1920
Depth     24

Only the SubSection "Display" with the Virtual line should be added, the rest is specific for my setup. 3360 is the height, 1920 is width. Just make sure that your virtual width and height is not less than your two resolutions added together. So, simply add both widths of both screens and use that number as virtual width. Virtual height is simply the largest height of one of your two monitors. In your case, it seems to be 3280 and 1050. amdcccle sometimes adjusts this automatically, but not always it seems. Restart your computer for the new xorg.conf to take effect. Good luck!

  • Thank you for the answer and for explaining the answer. It worked for me, although I don't know it works know. I've run through the same steps before. Anyway, I'm happy to see that it works now. Thanks! – OrangeTux Feb 6 '12 at 21:38
  • Good to hear! Have fun. ;) – Joost Van Durme Feb 10 '12 at 14:05
  • 1
    The proprietary ATI drivers don't work on my system (ccc crashes a lot). This worked a treat, though. Thanks. – Steve HHH Jun 4 '12 at 20:54

I receive the same message "The selected configuration for displays could not be applied" in 12.04. However, if you have an AMD video card you can solve it by starting "AMD Catalyst Center (Administrative)" and using its Display Manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.