0

The following packages have unmet dependencies: google-chrome-stable : Depends: libnss3 (>= 2:3.22) but 2:3.19.2.1-0ubuntu0.15.04.2 is to be installed E: Unable to correct problems, you have held broken packages.

This is the error I am getting when I try to install chrome. Netflix isn't working, facebook is slow too. Please help me out.

  • In the title you say upgrading, in the text you say installing. Which is it? – Organic Marble Mar 28 '18 at 4:13
  • Im sorry, the upgrade is not installing. I tried to remove chrome and install it again last night after posting this question. NOW m problem is that chrome is not installing from the software center. – Ubuntu newbie Mar 28 '18 at 8:02
  • when i try to install it from the software center, it asks me to repair broken packages and that doesnt work. There are many updates i need to complete from software update center, but those are not downloading either. Im lost. – Ubuntu newbie Mar 28 '18 at 8:03
  • 1
    Possible duplicate of Unable to correct problems, you have held broken packages – karel Nov 15 at 5:53
0

Please follow below steps:

  1. Go to the URL and download the libnss3 file
    https://packages.ubuntu.com/xenial/amd64/libnss3/download
  2. Click on the downloaded file, Ubuntu Software Center will open a dialog to repair. Click OK and authenticate yourself.

    Note: It will update the 'libnss3' library to latest version

  3. Download latest Chrome from https://www.google.com/chrome/
  4. Repeat step 2 and latest Google Chrome will be installed on your system.

Believe me it has speed up my browsing experience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.