1

I have a Sony Vaio with UEFI bios (can be changed to Legacy) and dual boot Ubuntu 16.04 LTS/ Windows 10.

The problem is the following:

  1. If I boot Ubuntu from GRUB, the next boot my computer boots from GRUB.
  2. If I start Windows from GRUB, the next boot my computer does not boot from GRUB and Windows starts without asking.

When my computer doesn't boot into GRUB and the boot gets forced to windows:

  1. I can use Super Grub2 Disk to boot Ubuntu: Boot Manually->Grub extract entries->Ubuntu.
  2. Next boot, after turning off the computer after entering Ubuntu with Super Grub2 Disk, GRUB is back.
  3. Again, If I boot Ubuntu from GRUB, the next boot GRUB is still there but if I start Windows from GRUB, the next boot GRUB does not start and Windows starts without asking.

Anybody knows how to repair it? I searched the internet and I can not find my specific case.

0

I used the program easyUEFI in Windows-10 changing the boot parameter in Windows, to use path \EFI\Ubuntu\grubx64.efi as default

  • Please add more information. As is, your answer is difficult to understand. – fosslinux Mar 27 '18 at 21:47
  • I've made a quick research about easyUEFI and Windows 10/Ubuntu dual boot and changing Windows path or dactivate Windows entry works the same way. So I deactivated it and now GRUB works fine. Thank you. – RubenStobbart Mar 28 '18 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.