0

I'm trying to run a game on my Lubuntu (Ubuntu) 17.10.1 install (specifically Pulsar Lost Colony, if that matters). It runs in an .x86 file and I have all the prereqs installed. The problem is it debugs and says that I don't have a new enough version of OpenGL to play, It says I need 3.2 or newer. However, my cpu (it's integrated) says that the gpu part supports OpenGL 4.3. The printout of glxinfo | grep OpenGL seems to give some indication of the issue:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.0-devel
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.1.0-devel
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.0-devel
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

I tried using the oibaf drivers after some googling but they didn't change anything even after a apt update and upgrade, and Intel doesn't appear to have graphic drivers for linux on its official site. Anyone have any idea how I can go about running this game by either overriding the expected opengl or getting it to properly support the 4.3 this cpu should support?

  • 1
    As per your output of glxinfo, OpenGL 4.5 is supported on your chip. However, only OpenGL ES 3.1 is supported there. Are you sure the game isn't using OpenGL ES? – dobey Mar 26 '18 at 19:38
  • What specific CPU do is this? The "minimum requirements" listed on the Steam page for the game, states Intel HD 5000 graphics, while most Haswell chips were still HD 4xxx. – dobey Mar 26 '18 at 19:43
  • I actually fixed it. ( see answer below) And yes, it may be requiring hd 5000 but I actually got it to work on 4600. My mistake, in hindsight it was simple. Thanks for taking the time to respond to me though! – Rob B. Mar 26 '18 at 19:47
1

I figured out the issue, for anyone else who may have similar problems here was the trick: glxinfo reports the x64 version of MESA (at least on my system it did) but the game needs the x86 version of MESA (it is an x86 executable, github issue report to the rescue!) which, interestingly, glxinfo didn't report on and since it is an x64 system I didn't have that installed.

When I installed steam to try the steam version, steam auto-installed the x86 version of mesa as part of installing the steam launcher, and voila, it worked! (don't know why it wasn't listed in game prereqs though). So for anyone else trying to run a x86 game and have tried much of other solutions and couldn't get it to work, make sure you have the x86 version of MESA and other x86 dependencies installed!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.