2

Last Tuesday, I performed an software update for Ubuntu and related software. Seeing how they required a reboot, I restarted my PC and went to log back in. Only to find that I could not log back in due to being kicked back to the login screen again and again.

Here were some symptoms before I tried to attempt a few fixes.

  1. Boot up was a bit slower than usual.

  2. There seem to be some screen color pixelation second before booting to the login screen. I presumed this has to do with some sort of graphics driver issue, since after I tried purging the NVIDIA drivers and reinstalling some different ones, that symptom has since disappeared.

I have looked around for a couple solutions thus far, though nothing concrete in terms of results except purging the NVIDIA drivers seemed to work. While I was able to login successfully after that, it messed up the UI to the extent that it rendered it unusable.

First it changed the font to something so tiny that it was difficult to read, and it also seemed to mess with the resolution as well. Additionally, I could no longer access the UI menu at the top of the screen upon logging in. So I was forced to shutdown and reinstall the NVIDIA drivers, which brought me back to step 1.

Tried a couple other things, including updating software to see if something was missed, but to no avail. Perhaps I missed a step.

I am still a relative newbie to using Ubuntu, so any help in step by step detail would be appreciated. I will provide additional details if requested.

EDIT March 31 2018 / 10:28 PM

Got some new logs that may be of interest. http://termbin.com/8wz4s http://termbin.com/jzef http://termbin.com/7nck

First two are xorgs. The last is dmesg.

  • You should probably check what update caused it: less /var/log/apt/history.log (navigate in the file with up/down arrows, exit with q). There should be an entry with a line containing the name of the package. – Reyssor Mar 26 '18 at 19:37
  • Should I also use the Xorg.log command? I have attempted to find the command for that one, seeing as it might be a driver issue with the graphics card, but I couldn't find it. Your command worked in bringing up some logs. Much appreciated. – Forlanceabice Mar 26 '18 at 19:54
  • Alright, I did some additional troubleshooting and got some logs. termbin.com/8wz4s, termbin.com/80pj, termbin.com/7nck. First two are xorg, the last one is dmesg. – Forlanceabice Apr 1 '18 at 3:28
0

I had something similar with my Mint 18 last evening after an upgrade of the package virtualbox-guest-utils. Solved it by removing all virtualbox packages: sudo apt-get remove virtualbox virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11

Followed by a reboot.

Not exactly a long term solution, but hopefully it will get you a usable PC until this get fixed.

  • So it allows you to login at least? Are there any drawbacks to doing such a thing? – Forlanceabice Mar 26 '18 at 19:23
  • @Forlanceabice Yeah, my system was back to normal. The drawbacks; well, no more Virtualbox for me until I reinstall a previous version. But since I don't use it anymore anyway, not a big loss. No guarantee that it's the same problem as yours though (especially if you never used Virtualbox before), just thought I would drop my situation here, just in case. – Reyssor Mar 26 '18 at 19:30
  • While I was taking screenshots back when I started researching the problem, I noticed there was a Failed to start LSB: VirtualBox Linux kernal Module. Shall I send you a screenshot of it for details? – Forlanceabice Mar 26 '18 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.