3

I’m working on getting an Ubuntu dual boot up and running on my desktop with windows. I have two separate SSDs, with Ubuntu 17.10 on an nvme drive and Windows 10 on a sata, so all that kind of stuff is set afaik. I can boot into ubuntu, and everything seems to work—except WiFi.

When I turn on the computer, it shows that it’s trying to connect for a while (WiFi symbol with three dots) and eventually gives up, but doesn’t tell me anything. I just tried forgetting the network and reconnecting, and it says it’s connected, but doesn’t work.

If I try to turn off WiFi altogether, it seems to freeze up, and I can’t do anything in the whole settings app. I think it’s related that it takes a very long time to shut down, to that point that I’ve just been forcing it to shut down.

I’ve tried everything I could find online about this issue that I thought applied, to no avail, so I figured I would turn to your guys’s expertise. I’m not sure what kind of information you need, so let me know. It's a USB card (TP Link TL-WN722N) if that makes a difference. I found this script and ran it, hopefully it gives any necessary info: https://pastebin.com/z4xZaDKi

If you need any more info I'll get it ASAP, but it probably won't be until the post is around 16 hours old.

Thank you!

2

For many years, in diagnosing and attempting to solve connectivity issues, I have preached to all:

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Your case seems like the perfect example. You can easily connect to:

Cell 01 - Address: <MAC 'ThisNetworkWorks' [AC1]>
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=40/70  Signal level=-70 dBm  
                    Encryption key:on
                    ESSID:"ThisNetworkWorks"
                    <snip>
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

But you cannot connect to:

Cell 02 - Address: <MAC 'Redacted1' [AC2]>
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=53/70  Signal level=-57 dBm  
                    Encryption key:on
                    ESSID:"Redacted1"
                    <snip>
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

As far as we can tell from the available data, the only difference is that the SSID that you can connect to is set up with WPA2-CCMP (sometimes known as AES) and the SSID that you cannot connect to is set up with WPA/WPA2 mixed mode and TKIP.

Please change the encryption mode in Redacted1 and tell us if you connect.

  • Unfortunately, that did not seem to solve the issue. Here's a new copy of the diagnostic file with that change made: pastebin.com/E4aZybfs – Ben K. Mar 27 '18 at 2:27
  • Your log shows that you connected perfectly but then, about a minute and a half later, disconnected. Did it drop by itself or did you disconnect? By chance, did it connect correctly but not pull any web pages? – chili555 Mar 27 '18 at 13:19
  • Yeah it said that it connected but the internet didn't work. – Ben K. Mar 27 '18 at 18:52
  • Please try: sudo dpkg-reconfigure resolvconf and reboot. Then: ping -c3 www.ubuntu.com – chili555 Mar 27 '18 at 21:13
0

The answer by @chili555 seems to be getting to the core of the problem. I experienced something similar after upgrading from ubuntu 18.04 to 20.04. My computer was able to connect to a mobile phone hotspot wifi which had the following parameters (on running this script)-

Cell 04 - Address: <MAC 'Ishank Juneja' [AC4]>
                    Channel:5
                    Frequency:2.432 GHz (Channel 5)
                    Quality=70/70  Signal level=-35 dBm  
                    Encryption key:on
                    ESSID:"Ishank Juneja"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000074e25c9ae
                    Extra: Last beacon: 4112ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

However, it was unable to connect to my TP-link home router which had the following parameters-

  Cell 01 - Address: <MAC 'Bishop' [AC1]>
                    Channel:5
                    Frequency:2.432 GHz (Channel 5)
                    Quality=48/70  Signal level=-62 dBm  
                    Encryption key:on
                    ESSID:"Bishop"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000006a83c50cf
                    Extra: Last beacon: 4112ms ago
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

So the problem seemed to be the same and I went to this webpage to try and change the settings to replace TKIP by AES/CCMP. I found the setting to do this under Advanced --> Wireless Settings --> Encryption however after changing the setting there from 'Auto' to AES and rebooting the router, neither the output on running the wireless script nor the connectivity problem changed.

On scouring the internet a bit more, I came across this forum answer and ran the commands mentioned there-

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlmvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

I am not quite sure of the implications of these commands however after running them, the connectivity problem with my TP-Link router was solved. However based on internet speed tests, I feel running these commands throttled my Laptop's internet speed by a factor of about 2-3. I suspect this may be due to some wifi driver issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.