I have a Logitech C510 webcam connected to my desktop running 64-bit Ubuntu 11.10, but it doesn't seem to be working when I run Cheese and Skype. After doing some search, it seems this webcam should just work out of the box. However, Cheese and Skype don't seem to work with it. With those programs loaded, the webcam appears in the list of video devices in their configurations, but the orange light indicator on the webcam does not turn on. However, I was able to get the webcam to work with the Adobe Flash plugin running in Chromium. I can open Flash settings and click on the webcam icon to get an image to show up. So the webcam seems to work fine, but Cheese and Skype can't seem to operate it. Any ideas about what might be causing this? Thanks.

1 Answer 1


Try experimenting with the hacks on this site: https://wiki.ubuntu.com/SkypeWebCams

The following worked for me:

Open Text Editor and enter:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

save as skype.sh

And set in permissions : Allow file executing as a program.

Edit the menu item by opening "Main Menu" from launcher or running alacarte in the command prompt. Find Skype and change the command to point to the script file.

  • Thanks for the advice. I tried that script but running it I get "ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored." Any idea what might be causing this? Also, it's not just Skype, it seems Cheese and Gstreamer can't operate the webcam either, but it works perfectly in guvcview. Could it be some issue with the webcam needing special drivers to turn on?
    – solarein
    Feb 7, 2012 at 20:54
  • The position of the v4l1compat.so might be different on different versions of Ubuntu. On my system (11.10) the path is: /usr/lib/i386-linux-gnu/libv4l/v4l1compat.so Also make sure you have the libv4l package installed. Instead of the script you may try to modify the menu loader to: env LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype
    – To Do
    Feb 8, 2012 at 13:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .