12

I'm trying to debug a C++ application using GDB and the Qt Creator IDE. Every time the debugger stops on a breakpoint, Ubuntu (v 17.10) thinks the application is frozen and issues the dialog box with the warning that "{application} is not responding" with options to force quit or wait. Waiting only results in the same dialog popping up 5 seconds later. The debugger is unusable while the dialog box is open. Is there a way to disable this warning entirely in Ubuntu?

Note 1: just found this question which is very similar but with Java.

Note 2: This happens in Gnome3 but not Unity. A temporary work-around is to log in using the Unity desktop.

Note 3: It appears this has been fixed in Ubuntu 18.04 (GCC 7.3).

  • 1
    That's going to be tricky I think - if I understand the issue correctly, it's because the debugger pauses the application's event loop, preventing it from responding to the window manager's _NET_WM_PING signal. – steeldriver Mar 25 '18 at 14:12
  • 1
    I don't know if you can see the (deleted) answer to the similar question you linked, but the answerer did file a bug report <something> is not respoding window is constantly showing when debugging a program in Eclipse (AFAIK the issue is the same regardless of either the debugger or application language) that you might want to add to ("affects me too") – steeldriver Mar 25 '18 at 14:12
  • 1
    Thanks for the link; I can't see the deleted answer. This issue must be tied to some specific configuration - I would think that not being able to use a debugger would cause an outrage if it affected everyone. – Carlton Mar 25 '18 at 14:26
1

There is a gnome shell extension to disable the force close dialog. It isn't the best solution but it helps working around apps that "lock" the GUI.

Download this

Extract it to $HOME/.local/share/gnome-shell/extensions/disable-force-quit@fmuellner.gnome.org/

Reload Gnome with Alt+F2, r, enter (it won't kill your session / apps)

Open Tweaks, under Extensions, activate it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.