10

I have HP G56 laptop and it originally came with Windows 7 which microsoft updated to windows 10 for free. I did clean install and so i don't have option to go back to windows 7.

I want to try Ubuntu as after upgrading to windows 10, my laptop runs slow. I have created bootable USB several times but can't make my laptop to boot. I saw tutorials and already setup bios to boot from USB first and also turnoff fast boot from power option. I can however use other USB for windows 10 that i have and that works but not from Ubuntu USB

29
  • 1
    1. Please tell us more about your computer - brand name and model; 2. Turn off secure boot in an UEFI system menu; 3. Which version of Ubuntu are you trying (name of the iso file)? 4. Did you check the iso file with md5sum? 5. How did you create the Ubuntu USB drive (which tool/method)? 6. Does the Ubuntu USB drive boot in another computer?
    – sudodus
    Mar 24 '18 at 20:38
  • 1
    I tried USB on my friend's laptop and it works so some settings are wrong or needed to be tweaked.
    – Poorav
    Mar 28 '18 at 11:45
  • 1
    I believe i do have BIOS mode (not UEFI) on my HP G56 laptop as i do not see UEFI option. I did made USB with Rufus-2.18 so let me ktry ubuntu 16.04.1 ISO instead of 16.04.4 ISO, hopefully that will work.
    – Poorav
    Mar 28 '18 at 11:49
  • 1
    reset bios to default, as may be you have some bad setting preventing boot from usb. Try also F9 during bios to display boot menu. Try another usb device (the fact it works on another pc don't mean it is ok for your pc)
    – laugeo
    Mar 31 '18 at 12:01
  • 1
    I truly appriciate your help. yes lets see what happens. One last thing though, i have win10 bootable use and it do work with this laptop. So i am not sure what bios setting would be wrong but ubuntu usb don't work
    – Poorav
    Apr 1 '18 at 13:38
8
+50

You commented that:

It gets a hangup at boot, it displays "press Esc to see startup option" and nothing happens. If I press Esc then it displays "press Esc to pause" and if press Esc nothing happens. Basically I have to turn off the laptop by pressing the power button.

The Ubuntu live USB that you made with the 1.5GB Ubuntu iso is not loading successfully, so try booting your laptop with the Ubuntu Minimal CD. The Ubuntu Minimal CD is less than 60MB in size, and loads the rest of the packages required to install Ubuntu during the installation process.


How to make an Ubuntu Minimal USB

It is possible to make an Ubuntu Minimal USB on either Ubuntu or Windows Subsystem for Linux 2 in Windows 10 using dd. While the minimal iso image is handy, it isn't useful for installing on UEFI-based systems that you want to run in UEFI mode. The mini iso lacks the proper files for booting the computer in UEFI mode. Thus the computer will boot in BIOS compatibility mode, and the installation will be in BIOS mode.

  1. Download the Ubuntu Mini CD iso file for Ubuntu 18.04 and earlier from the link on the Ubuntu Documentation Installation Minimal CD webpage. Download the Ubuntu Mini CD iso file for Ubuntu 20.04 from http://archive.ubuntu.com/ubuntu/dists/focal/main/installer-amd64/current/legacy-images/netboot/mini.iso. Download the file called mini.iso to your Downloads folder. You can download the mini.iso file to wherever on your computer that you want, but download it to your Downloads folder so that you can easily run the commands in the following steps without changing anything.

  2. Verify the md5 checksum of the Ubuntu mini CD iso file that you downloaded by running these commands:

    cd ~/Downloads/
    md5sum 'mini.iso'  
    

    If you are using Windows Subsystem for Linux download the Microsoft File Checksum Integrity Verifier tool from the official Microsoft Download Center. The Microsoft File Checksum Integrity Verifier tool is a command line utility that computes MD5 or SHA1 cryptographic hashes for files.

  3. Check that the results of the command match the MD5 checksum of the mini.iso file on the Ubuntu Documentation Installation Minimal CD webpage.

  4. Get a USB flash drive, 1GB or larger. Delete all the files from the USB flash drive. Mount the flash drive using the Disks disk utility. Or burn the Ubuntu Mini CD iso file to a CD.

  5. Check in the Disks disk utility to find out the device name of your USB flash drive. This is very important because if you use the wrong device name in step 6, you will overwrite your whole operating system instead of writing to the USB flash drive. So check the USB flash drive device name twice. It should be something like /dev/sd* where instead of the * character there is a lower case letter like a, b, c, etc. In the following step I am assuming that the device name is /dev/sdc, but the device name of your USB drive could be something else like /dev/sda or /dev/sdb so check the device name of your USB drive twice and make sure that you get it right in step 6!

  6. Open the terminal or Windows Subsystem for Linux and run the following commands:

    cd ~/Downloads/  
    sudo -i  
    dd if='mini.iso' of=/dev/sdc bs=4096  ## make sure that the device name of your USB drive is correct!
    

    The dd if='mini.iso' of=/dev/sdc bs=4096 command should take only a few seconds to complete on most computers because the mini.iso is a small file, less than 60MB. The result of running this command will be a bootable Ubuntu mini USB.

  7. Boot the computer from the Ubuntu mini live USB (or CD). The Ubuntu mini live USB (pr CD) should boot successfully and show a menu screen.

  8. If you select the Install option (the complete install, not the cli install) from the menu screen in Step 7, then you can select other options during the Ubuntu installation process to download all the packages that you need to perform a complete Ubuntu installation. Select the Ubuntu desktop package collection from the list of predefined collections of software in the Software selection screen in the Ubuntu mini CD installer. When you restart the system at the end of the installation, you will have a working Ubuntu desktop with the default desktop environment.

    enter image description here

2
  • +1. I would be even happier, if you suggest a safer alternative than dd. There are tools with a final checkpoint ... :-) -- Let us wait and see if @Poorav is helped by this method; maybe we must also help at the BIOS/UEFI level to make the computer boot from USB.
    – sudodus
    Mar 31 '18 at 8:19
  • Talking about tools with a final checkpoint, I can refer to this link: Accidentally did dd /dev/sda. You can scroll down to 'Safer tools to create USB boot drives with Ubuntu'.
    – sudodus
    Apr 6 '18 at 8:54
5

My laptop suffered from similar problem, what i did is that i

1- disabled 'fast BIOS Mode' under the advanced settings.

2- disabled 'UEFI Boot support' (although my laptop doesnt have UEFI but this option is there is the BIOS settings, after disabling these it recognises the bootable usb)

4
  • 1
    i also have BIOS mode (not UEFI) but still that option is there in boot settings....
    – waqar
    Mar 31 '18 at 11:40
  • 1. I have disabled fast bios but no luck
    – Poorav
    Apr 1 '18 at 13:46
  • 2. I do not see UEFI boot support in bios settings
    – Poorav
    Apr 1 '18 at 13:46
  • FYI, my bios version is Hewlett-Packard F.15, 4/7/2011. I
    – Poorav
    Apr 1 '18 at 13:48
1

I remember having this problem on an older laptop a year or two ago. It probably has something to do with how the computer is trying to start. Sometimes UEFI won't launch a Legacy USB and vice versa. Make sure you're iso file is for UEFI booting or disable that and use Legacy, but then you need to make sure that your iso file is the one that boots with Legacy.

1
  • 2
    Not sure how i do this?
    – Poorav
    Apr 1 '18 at 13:51
1

Try to put your bootable media in USB 3.0 ports instead of 2.0 It seems that 2.0 ports are totally frozen in my case. Ubuntu does not recognize any input in the test mode of bootable usb media and also after I managed to inatall the entire OS including keyboard or mouse.

2
  • 3
    Also the reverse is sometimes true. If USB 3.0 ports don't work try inserting the USB bootable media in a USB 2.0 port. Also sometimes trying any other USB port works. And if none of these work sometimes trying a different USB stick works.
    – karel
    Dec 24 '18 at 14:41
  • 1
    I have just experienced this issue in a HP 15-bc451ns, where Ubuntu 18.10 doesn't load in a USB3.0 (marked as USB SS) but yes in a USB 2.0
    – Nothor
    Jan 24 '19 at 19:28
0

I have been struggling for ten years with the problem that an older computer (32 Bit Acer Aspire One) BIOS does recognize my USB .iso file. I just today found the answer from a wiser man than I and I want to share this with all of you.

Here is how to do it properly: If your computer has only LEGACY boot mode, the USB stick has to have a MBR (Master Boot Record) partition table before making a .iso installation (boot) file. And the USB should have a single FAT32 partition.

If your computer is in UEFI boot mode, the USB stick has to be formatted to have a GPT (GUID Partition Table) partition type.

So in short: if your USB has a GPT partition table, it won’t work in legacy-computer, and if your USB has a MBR-partition table, it won’t work in UEFI-computer (might work since UEFI is the new standard and may be backwards compatible).

THE SOLUTION IS: Change partition table type (MBR vs GPT) of the USB to correspond the boot mode of the computer (Legacy vs UEFI).

In Linux you can change partition table type of the USB stick in GParted or KDE Partition Manager and your problem is solved: Your computer now recognizes the USB stick!!!!

Sometimes GParted and KDE Partition Manager won't do the job. Then you have to use program called Disks, which will erase old partition table and create new.

However, when I tried to re-do an install to the same Acer Aspire One, it did not succeed.

After multiple attempts and hours of research, I did find a writing that said that another USB device connected to port near USB stick may cause the computer not to recognize the USB iso-stick.!!!

I had a mouse connected to port next to USB stick and removing the mouse everything worked again: Computer recognized the USB .iso and started booting from it.

So remove all other USB devices before inserting an USB .iso.

UPDATE: Trying to boot from USB iso third time gave following error: USB 5-5 device descriptor read/64, error -71 and solution was found in here:

By adding the following line to /etc/modprobe.d/options (I did not have an options file there, it had a different name):

options usbcore use_both_schemes=y

computer recognized USB stick and it solved this problem.

0

I was unable to boot from USB key with an ASUS N53s Laptop with a key made from Lunbutu V18 to setup an Ubuntu V20.

Seems the key use the UEFI mode. The BIOS saw it, the GRUB menu was displayed but stalled after pressing Enter key.

So I reinstalled the key from Windows using Rufus (look like it make a not UEFI one) and I used the "Bypass boot order" or "Boot override" section provided by the ASUS BIOS. The section list all the connected USB devices, you select the one you want to boot in directly and it worked !

Putting the USB key, first in the boot order was no enough, it was looping into the BIOS menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.