0

Hibernate has always worked for me, set it to hibernate after 2 hours in system settings. Would wake it up with the power button in the morning.

Suddenly it stopped working. Every morning it is still up. Tried selecting Suspend from the menu the system acts like it is going to sleep, i.e. the keyboard lights go off, monitors go off, etc, but then it come right back up.

Dmseg:

[  479.172551] PM: Syncing filesystems ... done.
[  479.180451] PM: Preparing system for mem sleep
[  479.180575] Freezing user space processes ... (elapsed 0.001 seconds) done.
[  479.182373] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[  479.183589] PM: Entering mem sleep
[  479.183611] Suspending console(s) (use no_console_suspend to debug)
[  479.183914] sd 2:0:0:0: [sda] Synchronizing SCSI cache
[  479.185589] sd 2:0:0:0: [sda] Stopping disk
[  479.186962] serial 00:0c: disabled
[  479.186966] serial 00:0c: System wakeup disabled by ACPI
[  479.186997] i8042 kbd 00:0a: System wakeup disabled by ACPI
[  479.187104] parport_pc 00:05: disabled
[  479.508035] PM: suspend of devices complete after 324.202 msecs
[  479.508251] PM: late suspend of devices complete after 0.213 msecs
[  479.508361] pcieport 0000:00:1c.0: System wakeup enabled by ACPI
[  479.540141] PM: noirq suspend of devices complete after 31.888 msecs
[  479.540400] ACPI: Preparing to enter system sleep state S3
[  479.540586] PM: Saving platform NVS memory
[  479.540737] Disabling non-boot CPUs ...
[  479.644052] smpboot: CPU 1 is now offline
[  479.644215] ACPI: Low-level resume complete
[  479.644215] PM: Restoring platform NVS memory
[  479.644215] Enabling non-boot CPUs ...
[  479.644215] x86: Booting SMP configuration:
[  479.644215] smpboot: Booting Node 0 Processor 1 APIC 0x1
[  479.657736] CPU1 is up
[  479.659085] ACPI: Waking up from system sleep state S3
[  479.736216] PM: noirq resume of devices complete after 76.963 msecs
[  479.736309] PM: early resume of devices complete after 0.069 msecs
[  479.736398] snd_hda_intel 0000:00:1b.0: irq 43 for MSI/MSI-X
[  479.736497] usb usb3: root hub lost power or was reset
[  479.736524] usb usb2: root hub lost power or was reset
[  479.736546] pcieport 0000:00:1c.0: System wakeup disabled by ACPI
[  479.736622] usb usb4: root hub lost power or was reset
[  479.863636] usb usb5: root hub lost power or was reset
[  479.865165] parport_pc 00:05: activated
[  479.865511] serial 00:0c: activated
[  480.048256] ata1.00: ACPI cmd ef/03:44:00:00:00:a0 (SET FEATURES) filtered out
[  480.048258] ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[  480.048260] ata1.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[  480.064153] ata1.00: configured for UDMA/66
[  480.156109] ata3.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[  480.156111] ata3.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[  480.158075] ata3.00: ACPI cmd c6/00:10:00:00:00:a0 (SET MULTIPLE MODE) succeeded
[  480.158077] ata3.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[  480.198089] ata3.00: configured for UDMA/133
[  480.198108] sd 2:0:0:0: [sda] Starting disk
[  480.332020] usb 2-2: reset low-speed USB device number 2 using uhci_hcd
[  480.880048] usb 3-2: reset low-speed USB device number 2 using uhci_hcd
[  481.197035] PM: resume of devices complete after 1460.723 msecs
[  481.197278] PM: Finishing wakeup.
[  481.197279] Restarting tasks ... done.
[  481.791677] r8169 0000:02:00.0 eth1: link down
[  481.791687] r8169 0000:02:00.0 eth1: link down
[  481.791813] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[  483.788986] r8169 0000:02:00.0 eth1: link up
[  483.789000] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
0

Based on the log, it looks like the system received an event that took it out of sleep immediately.

Have you started using any new USB devices, like a new mouse or keyboard?

What I found doing research is that it's likely a device sending the signal to wake up when it shouldn't be.

1
  • Nope same old devices. Indeed, tried unplugging everything. Will update with contents of /proc/acpi/update when I get a chance to test again, have usb devices in use atm. – sunshine Mar 25 '18 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.