0

Trying to install Xubuntu (xubuntu-16.04.4-desktop-i386.iso) on Acer Aspire One notebook that already had Ubuntu 14.04 installed. On booting from the prepared USB drive, Xubuntu does start after the following 2 errors are displayed briefly while booting:

[   0.108721] ACPI Error :  [CAPB] Namespace lookup failure, AE_ALREADY_EXISTS (20170531/dsfield-211)
[   0.108798] ACPI Error :  Method parse/execution failed /_SB.PCI0._OSC, AE_ALREADY_EXISTS (20170531/psparse-550)

(I'm really hoping this means something to someone as it doesn't mean anything to me!)

These errors are displayed for only 30 seconds or so then the install seems to run fine and I get the "install completed. Please restart" message, however after restarting, the screen shows only part of the desktop!

The screen is mostly black except for a strip down the right side that is normal i.e. the top right corner shows the battery state icon, connection, volume and date/time and everything below is the normal blue desktop! The right-click menu is there but if the actions work they are largely or completely invisible i.e. in the black part of the screen.

I have tried installing repeatedly but with the same result. I have run the disk checking utility on the installation menu which reports everything OK.

I think the problem may be that I removed the USB before being prompted on the restart so it may have corrupted something. Is there a way I can reformat the hard disk or something before installing?

Please let me know what has to be done to fix this as I am really taken with Xubuntu.

  • Just discovered and can see Terminal – Rick Mar 24 '18 at 10:51
1

I'm not sure about the two error messages, sometimes they're just warnings and everything still works ok.

But the funny screen size sounds like the monitor's being told to use a size it can't do. Could try changing the resolution in the Display settings

  • Display in the Settings sub-menu
  • or All Settings -> Display
  • or run xfce4-display-settings in a terminal to open the window

If the window opens, ALT+Space then M should let you move the window with the arrow keys, to get it somewhere you can see & change the settings. (It looks like there's keyboard keys that should change the settings, like E for resolution, but they don't seem to work for me.)

That's assuming the live USB booted & ran ok in the live "Try Ubuntu" mode... if it didn't then you might need a kernel boot code like nomodeset to get it working. Searching for your notebook's model and "Ubuntu" should find others with the same problem, and hopefully their solution.

  • I changed to the next lowest resolution and the whole screen went black. It was set on the highest available resolution. So I'm sorry but this wasn't a solution for me. – Rick Mar 24 '18 at 22:46
  • I tried installing Lubuntu, and thought it had worked as it went through the whole install including updates, but after rebooting I got the same problem - 80% of the screen is black background, but this time there are strange machine code like characters visible. All I can see of the desktop is a narrow strip down the right hand side. Also, it doesn't shut down. Its just one very sick notebook, and I really don't know what to do with it. – Rick Mar 24 '18 at 22:54
  • That's disappointing, maybe it's a hardware driver problem (or just a hardware problem period). Did booting with nomodeset do anything different? Should probably boot the GUI successfully, but in a very low resolution. – Xen2050 Mar 25 '18 at 14:21
  • Thanks again - I haven't tried booting with nomodeset yet as I want to learn what it is, and what it does! It does sound promising though. – Rick Mar 26 '18 at 11:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.