0

I just installed Ubuntu 17.10 alongside Windows 8.

My wifi router isn't working so I am stuck with using a hotspot from Samsung Galaxy S Duos. Ubuntu recognizes the hotspot network but when I try to connect it, it attempts to connect and without any message or error stops trying.

I tried several times, changed passwords, changed security types but no success. For a brief moment, it did connect but it did not work and quickly disconnected again.

What should I do?

Note: Also the Broadcom driver is not present for some reason. Is there a way to download it from Windows and install on Ubuntu. I think that might resolve my problem.

  • Why do you think you need the broadcom driver? Use USB tethering to the phone and edit the question to include results for the wireless script – Jeremy31 Mar 24 '18 at 12:12
0

You should plug your device to an Internet cable and run terminal and run this very simple command :

sudo apt-get update

then after completing that process, you'll find out Broadcom wireless driver in the "Additional Drivers" tab of the "Software & Updates" app. install it and you'll be able to connect to any wireless connection you want. I had a problem like yours and fixed it with this simple way, hope it works for you too!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.