0

For the life of me I cannot find documentation stating one way or another if S/PDIF output is possible on the Dell XPS 15 9560 via the 3.5mm jack.

I've been working under the assumption that it is supported but, after several hours trying various commands and such, cannot get it to work.

Hoping someone here can either tell me I'm being dumb and it isn't even supported or help me get this working. Happy to provide any additional information, pictures, etc. if it will help.

Basically, I'm trying to use a Toslink to Mini Toslink cable to connect my laptop and external amplifier (Astro A40 Mixamp) but have no Digital Output options of any kind.

Laptop > Mini Toslink end of cable into 3.5mm jack > Toslink end of cable into external amplifier

The cable I'm using in case it matters

Under Settings > Sound > Output Tab I only have "Speakers (Built-in Audio)" available as a selection until I plug my headphones directly into the 3.5mm jack. At that point a headphones option appears which seems normal enough.

However, if I plug the Mini Toslink end of a Toslink to Mini Toslink cable into the 3.5mm nothing changes/happens and there is no light coming through the cable (have verified the cable is fine via a desktop system I have).

output of uname -a

Linux snip 4.13.0-37-generic #42~16.04.1-Ubuntu SMP Wed Mar 7 16:03:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

output of lsb_release -a

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.4 LTS
Release:    16.04
Codename:   xenial

output of aplay -l   (notice there is no ALC3266 Digital)

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

output of cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version k4.13.0-37-generic.

relevant output of lshw -c sound

*-multimedia
   description: Audio device
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 1f.3
   bus info: pci@0000:00:1f.3
   version: 31
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list
   configuration: driver=snd_hda_intel latency=32
   resources: irq:145 memory:ed128000-ed12bfff memory:ed100000-ed10ffff

output of lsmodo | grep snd

snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek    94208  1
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          40960  3
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_usb_audio         196608  3
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_usbmidi_lib        32768  1 snd_usb_audio
snd_hwdep              20480  2 snd_hda_codec,snd_usb_audio
snd_pcm                98304  6 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core,snd_hda_codec_hdmi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  2 snd_seq_midi,snd_usbmidi_lib
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    81920  24 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd

output of cat /proc/asound/card0/code* | grep Code

Codec: Realtek ALC3266
Codec: Intel Kabylake HDMI

output of cat /proc/asound/pcm

00-00: ALC3266 Analog : ALC3266 Analog : playback 1 : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
00-09: HDMI 3 : HDMI 3 : playback 1
00-10: HDMI 4 : HDMI 4 : playback 1

alsamixer

screenshot of alsamixer after fresh reboot:

alsamixer screenshot showing available channels

I've tried messing with all the S/PDIF options that show up but they're all associated with HDMI (see below).

pavucontrol

In pavucontrol under configuration, the Built-in Audio section shows no non-hmdi Digital Output options. I can't figure out how to take a screenshot with the dropdown options showing but there's:

  • Analog Stereo Duplex
  • Analog Stereo Output
  • Digital Stereo (HDMI) Output + Analog Stereo Input
  • Digital Stereo (HDMI) Output (unplugged)
  • Digital Surround 7.1 (HDMI) Output + Analog Stereo Input
  • Digital Surround 5.1 (HDMI) Output + Analog Stereo Input
  • Digital Surround 7.1 (HDMI) Output (unplugged)
  • Digital Surround 5.1 (HDMI) Output (unplugged)
  • Analog Stereo Input

Note: The options with (HDMI) repeat for HDMI 2, HDMI 3, HDMI 4, and HDMI 5

/etc/modprobe.d/alsa-base.conf

I tried adding the following to my alsa-base.conf but it didn't change anything as far as I can tell. Perhaps I need my exact model. If so, what would it be?

options snd-hda-intel model=auto

Manual Realtek Driver notes

I also tried manually make install'ing the drivers (Linux driver (3.0) - 5.18rc8) from Realtek's site but got make errors. Read in a few places that newer kernels would contain these anyway so abandoned this effort.

0

Turns out the Dell XPS 15 9560 DOES NOT support digital (S/PDIF) audio output via the 3.5mm jack. Disappointing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.