I have digitalocean droplet ( a server). I restarted the droplet. Then Boot drops to a (initramfs) prompts/busybox. I found a solution:

Ubuntu 15.10 - "BusyBox built-in shell (initramfs)" on every boot

But fsck command not available. Available Commands are:

Available Commands

The error is:


What can I do about that?

  • I highly recommend that you read the duplicate answer that you found again. The available command you want is exit – Elder Geek Mar 24 '18 at 3:01
  • @ElderGeek I don't see how that answers the question. OP ran exit (see screencap) but the error isn't saying the partition is damaged, it's saying the partition doesn't exist. (Though I don't have much experience with this sort of thing.) – wjandrea Mar 24 '18 at 17:07
  • @wjandrea I see that now. It's more clear to me since the edit 5 hours ago. – Elder Geek Mar 24 '18 at 18:57
  • Either the root device has failed or there's a misidentification of the UUID in fstab.. – Elder Geek Mar 24 '18 at 19:01
  • I explained how I solved the problem. – GG gg Mar 24 '18 at 19:12

This issue is caused by the UUID in the /etc/fstab file not matching the UUID of the disk itself. DigitalOcean Support team have set my Droplet to boot to recovery mode. Then I power off and on the Droplet from the control panel. From the recovery mode, I mounted my droplets disk. I viewed the correct UUID with the command "blkid" and then edit the /mnt/etc/fstab file after mounting my disk to correct this. Then I power off and on the Droplet from the control panel once again. DigitalOcean Support team set the Droplet to boot normally. Then droplet worked very well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.