0

I have some problems with my ubuntu after I upgraded from 17.04 to 17.10

gnome-terminal isn't working. I tried to fix it for few hours without any success.

When I'm running gnome-terminal from xterm(that does work) I get a python syntax error due to the line "print url" - what suggests that it is a python2 script. So I changed /usr/bin/gnome-terminal file to run with python instead of python3.

Then I got some problems related to gi package. I searched for solutions and tried after reinstall gi, but then I got this error:

from gi-repository import GLib, Gio importError: no module named repository

I found out that gnome-terminal.real works. But I've no idea how to fix this python problem. Any help will be much appreciated

Thanks

1 Answer 1

0

I've checked the /usr/bin/gnome-terminal wrapper script shipped by Ubuntu 17.10's gnome-terminal package. It contains no print url – in fact, contains neither the word print nor url. You probably modified this script or installed an unofficial version.

Please reinstall gnome-terminal and gnome-terminal-data from the official Ubuntu repositories. Also make sure that all the package dependencies are satisfied, the gi-repository imports should succeed then.

3
  • The error message, when I use python3.6, is: File "/usr/local/lib/python3.6/dist-packages/gi/__init__.py", line 39 print url
    – M H
    Commented Mar 25, 2018 at 15:17
  • your answer encourages me to check again more deeply the error message. I found out it's about gi package in python3.6. After a short google search, I found I need to uninstall gi package and it solved the problem. Thanks a lot!
    – M H
    Commented Mar 25, 2018 at 16:08
  • If installing an additional package breaks gnome-terminal then this is something you should file into Ubuntu's bugtracker and its developers should investigate.
    – egmont
    Commented Mar 25, 2018 at 19:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .