14

I'm using Ubuntu 17.10.

I formatted an USB pen-drive to NTFS to prepare a Windows7 USB Installer.

I set the bootable flag on this pen-drive and copied the files into it.

EDIT 1: The USB pen-drive is automatically mounted by udev.

umount /dev/sdb1 takes from 10 upto 12 minutes to complete.

Here are the mount options :

$ mount | grep sdb
/dev/sdb1 on /media/mansfeld/Win7_USB_Installer type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

EDIT 2: The cp operation is not INSTANTANEOUS at all, it took 3 minutes to copy the files to the USB pen-drive.

EDIT 3: The sync operation (done right after the cp) took 12 minutes to complete ! But then the umount will be instantaneous.

For FAT32, (with sync also disabled during mount), I notice the same behaviour.

Any ideas why it takes so long to unmount NTFS USB pendrive ?

4
  • 1
    How do you unmount it (which command or GUI action)? Did you try with the following command line? sudo umount /dev/sdb1; Maybe there are some buffered data, that must be written to the drive before it can be unmounted. You can flush the buffers with sync ; After sync has returned to prompt, unmounting should be fast.
    – sudodus
    Mar 23, 2018 at 18:53
  • 1
    @sudodus The computer on which I ran this is at the university so I'll have to wait 'till monday to try and time the sync command.
    – SebMa
    Mar 25, 2018 at 9:34
  • 2
    I noticed your edit. This is according to my experience. Copying takes some time (at first it is fast (writing to RAM), but after a while, it must flush the buffer (when it is full or almost full according to some rule), and the copying will be slower). Yet, when the copy command finished (cpreturns to prompt), there are still lots of data in the buffer. If you run sync right after the cp command, and wait until sync returns to prompt, the unmount should be fast. Please try that :-)
    – sudodus
    Mar 26, 2018 at 14:50
  • I think you know now :-)
    – sudodus
    Mar 26, 2018 at 18:59

2 Answers 2

10

You are probably suffering from buffering caching. To speed up writing to USB sticks (and hard disks in general), Linux uses a filesystem cache:

When you (think you) write something to the stick then it is first written to the cache (in RAM) and the cp command (for instance) returns immediately pretending a really fast write operation. While you do other things, the contents of the cache is then written to the stick in background. You may notice that an LED on the stick still flashes showing write operations (depends on your stick) although nothing apparent happens.

When you issue umount soon after a write operation, then umount waits until all the filesystem's cache content is written to the stick in order to make sure no data gets lost.

With sync you can manually force emptying the cache and writing the data to the stick. However, this won't speed up the total elapsed time because then you will have to wait for the sync to complete (instead of waiting for umount). But the umount will then return instantaneously because the cache is already flushed.

In summary you have three choices after copying large or many files to the stick:

  • umount and wait 10 minutes for it to complete
  • sync, wait 10 minutes to complete, followed by umount (will return almost immediately)
  • simply wait for 10 minutes (perhaps a bit more) and do nothing (or something unrelated to the stick) and then issue umount. Because the cache gets written in background automatically, umount will then return almost immediately as well.
6
  • 3
    Or mount the filesystem with -o sync flag enabled, that disables write caching. Mar 25, 2018 at 13:18
  • Yes, @Pasi, that's another reasonable approach. Thank you for pointing that out. But then the "10 minutes" will kick in when you actually cp the files. It just depends on what behaviour you prefer. Waiting for cp or waiting for umount.
    – PerlDuck
    Mar 25, 2018 at 16:39
  • @PasiSuominen How can I have udev mount my USB pen-drive automatically with the sync option enabled ?
    – SebMa
    Mar 26, 2018 at 18:03
  • /etc/udev/rules.d/ is your answer. In udev rule you can specify mount parameters. Mar 26, 2018 at 19:50
  • @PasiSuominen On ubuntu server, this dir is empty, what else can I do ?
    – SebMa
    Mar 27, 2018 at 8:48
5

When you copy files to your pendrive, they are not written on it directly. Filesystem synchronization is happening on unmount command, the actual data is written while you wait your unmount. If you execute sync before umount, the umount is instant.

2
  • The computer on which I ran this is at the university so I'll have to wait 'till monday to try and time the sync command.
    – SebMa
    Mar 25, 2018 at 9:34
  • I'll have to wait till monday for the sync to finish!
    – Owl
    Jul 3, 2019 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.