1

I did a speed test for my ubuntu and the wifi connection is capable of speeds up to 55 mbps but usually, it stays less than 1 mbps. My phone which is on the same wifi has speeds of about 50 mbps. I've tried disabling ipv6, it made no difference so I enabled it. I tried to force disable the 802.11n protocol with

sudo rmmod iwlwif

but I get this error: rmmod: ERROR: Module iwlwif is not currently loaded

So i am guessing 802.11n is disabled already? my wireless card is

  sudo lshw -c network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 10
       serial: d0:17:c2:1c:83:10
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:16 ioport:d000(size=256) memory:dfb04000-dfb04fff memory:dfb00000-dfb03fff
  *-network
       description: Wireless interface
       product: RTL8821AE 802.11ac PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 00
       serial: b0:c0:90:68:76:0b
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8821ae driverversion=4.13.0-37-generic firmware=N/A ip=192.168.50.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:17 ioport:c000(size=256) memory:dfa00000-dfa03fff

Keep in mind that at home, my internet wifi works fine after hours of finding the right drivers for my realtek wireless card. But at work it is barely working. I got the drivers from this page

Realtek Wifi Card RTL8723be Not Working Properly

but instead of pulling from rtlwifi_new I pulled from rtlwifi_new-master. It gave me errors when I pulled from rtlwifi_new

cd Desktop
cd rtlwifi_new-master
make
sudo make install
sudo modprobe -rv rtl8821ae
sudo modprobe -v rtl8821ae ant_sel=2
sudo ip link set wlp3s0 up
sudo iw dev wlp3s0 scan
echo "options rtl8821ae ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8821ae.conf

Right now I'm going to try ant_sel=1 or X to see if it makes a difference.

Thank you so much for the help!!

  • I don't believe the driver rtl8821ae has an ant_sel parameter to change. Check: modinfo rtl8821ae – chili555 Mar 23 '18 at 20:37
  • @chili555 I checked and ant_sel does not appear anywhere among the parameters....would deleting it make a difference? – he liu Mar 23 '18 at 20:53
  • There is only one way to find out: delete it. sudo rm /etc/modprobe.d/50-rtl8821ae.conf Reboot and report the result. – chili555 Mar 23 '18 at 20:58
  • @chili555 i did the deletion. When i was at home over the weekend everything was fine as usual. somehow the connection here at work is still bad. i really appreciate your help! – he liu Mar 26 '18 at 14:52
  • Possibly related: github.com/lwfinger/rtlwifi_new/issues/323 – chili555 Mar 26 '18 at 16:20
1

Let's try another newer version of the driver:

cd rtlwifi_new-master
sudo make uninstall
sudo modprobe -r rtl8821ae
cd ..
sudo rm -rf rtlwifi_new-master
git clone -b extended https://github.com/lwfinger/rtlwifi_new
cd rtlwifi_new
make
sudo make install
sudo modprobe rtl8821ae

Any improvement?

EDIT: In your scan we see:

Cell 03 - Address: xx
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70  Signal level=-40 dBm  
                    Encryption key:on
                    ESSID:"sdcwireless WiFi"
                    <snip>
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    <snip>
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

Ideally, we’d love to see these changes made:

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

As well, we’d love to see the SSID renamed to one without a space in the name, such as sdcwireless_WiFi.

Usually, Linux drivers are troubled by TKIP; as well, it is quite insecure: https://en.wikipedia.org/wiki/Temporal_Key_Integrity_Protocol

TKIP itself is no longer considered secure, and was deprecated in the 2012 revision of the 802.11 standard.

We hope you are able to convince the company to secure the network.

We also see, in your message log:

[ 3313.007137] _rtl_pci_interrupt: 417 callbacks suppressed
[ 3318.009871] _rtl_pci_interrupt: 1732 callbacks suppressed
[ 3323.014813] _rtl_pci_interrupt: 2015 callbacks suppressed
[ 3328.018509] _rtl_pci_interrupt: 2167 callbacks suppressed

Let’s try a driver parameter to see if it helps:

sudo modprobe -r rtl8821ae
sudo modprobe rtl8821ae int_clear=0

If it helps, we’ll make it permanent.

  • speedtest.net/result/7173642236.png no sorry still doesnt work. isnt that the same repo i pulled from before? why is it a newer version? i remember it is that link i used. – he liu Mar 26 '18 at 17:29
  • You indicated you pulled the master branch. This is extended. – chili555 Mar 26 '18 at 18:51
  • does this sound more like a problem with the router and IT dept and not the actual computer? – he liu Mar 26 '18 at 19:59
  • I'm still not sure. Please run: sudo iwlist scan at the office. Obscure the MAC address with xx:xx or some such and then run: dmesg | grep rtl Paste both here and give us the link: paste.ubuntu.com – chili555 Mar 26 '18 at 20:08
  • paste.ubuntu.com/p/KWnXvfCzR4 thank you! – he liu Mar 26 '18 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.