NetworkManager-wait-online.service fails at boot and it delays my startup

  • Waits for the network to come online. – Soren A Mar 23 '18 at 14:48

Some code runs off the network

In some multi-user environments part of the boot-up process can come from the network. For this case systemd defaults to waiting for the network to come on-line before certain steps are taken.

Majority of Desktop Users

Unlike some multi-user environments most Ubuntu desktop users have the Operating System and drivers on their hard disks, SSDs or Live Boot USBs.

There is a glitch where some users wait an extremely long time for network to come up during boot. In this case the recommendations is to set the maximum wait time to 30 seconds. A better way is to simply disable the service at boot time.

For many users 10 to 15 seconds can be sliced off the parallel boot time by using:

sudo systemctl disable NetworkManager-wait-online.service

After you sign on you will likely get a message bubble stating you've now been connected to the network (WiFi or Ethernet access to Internet).

  • Is it needed if I use a wireless keyboard and mouse as input to my system (works with a wireless receiver adapter plugged into USB port)? – Porcupine Jun 15 '18 at 15:10
  • 1
    No its not needed for USB. – WinEunuuchs2Unix Jun 15 '18 at 15:11
  • 2
    Bluetooth is often embedded in WiFi card so I'm not sure on that one. – WinEunuuchs2Unix Jun 15 '18 at 17:37
  • 4
    Why does it take so long to get a connection? I'm connected via Gigabit. – Corni Jun 8 '19 at 8:02
  • 1
    @Corni That is an excellent question but I'm not an expert on LAN/WAN/WiFi topology. I imagine it is something to do with negotiating new leases but that is just a guess. If you're really curious you can post that as a new question on this site. For me it's a shrug shoulders: it is what it is fact of life. – WinEunuuchs2Unix Jun 8 '19 at 15:25

It appears that this service simply waits, doing absolutely nothing, until the network is connected, and when this happens, it changes its state so that other services that depend on the network can be launched to start doing their thing.

So, it appears that this service is absolutely benign, it does not waste any time during boot, and it actually constitutes an optimization, so you are only going to make things worse if you disable it.

(Services that need the network will start before the network is up, at a time when many other services are also starting up and contention is high, and these services will be unable to do anything useful, so they will just keep retrying to connect to the network, until the network finally comes up.)


From the man page:


       systemd-networkd-wait-online.service, systemd-networkd-wait-online -
       Wait for network to come online
  • My service on Kubuntu 18.04.1 is called NetworkManager-wait-online.service and running man returns that there is no man page. Presumably this is a case of bad naming, or a missing link connecting man NetworkManager-wait-online.service with the man page named services you mention? – pbhj May 21 '19 at 15:07

For me this is the case because my Cisco switch wasn't configured spanning-tree portfast on the interface my workstation connects to the switch on. For whatever reason the switch takes a long time to bring up the interface if portfast is not configured.

You wouldn't want to enable portfast on a switch interface that has more than one downstream computers connected to it - probably results in only one computer having connectivity. But then again if you have multiple downstream computers connected to the switch interface (via a switch for example) then you wouldn't see this behavior in the first place.

Not the answer you're looking for? Browse other questions tagged or ask your own question.