1

I currently have 12.04 LTS installed and was trying to update to 16.04.4 LTS however I got myself in a bit of mire :(.

  1. I created a bootable USB containing 16.04.4 LTS and installation was going great until the end when I got hit with an error message grub-efi-amd64 package failed to install...
  2. I repeated above and obtained same error however in doing so I added another partition to my disk resulting in 2 copies of 16.04.4 getting written.
  3. I have checked some answers and tried some stuff to resolve without success
  4. Booted from USB and ran try Ubuntu & installed/ran boot_repair and generated a boot-info file
  5. I then tried to run Gparted to remove the last installation of 16.04.4 - so deleted sda6 partition.
  6. Reran boot-repair to get boot-info
  7. The file has some comments about what needs done - looking for sanity check before I commit to running boot-repair in repair mode

I checked system BIOS settings and boot order defined for both UEFI & Legacy support / Legacy support enabled & secure boot disabled If any other information is needed let me know.

0

I tried a few more things

  1. Used Gparted to delete all partitions with 16.04.4 LTS
  2. Read that this issue could be resolved if I booted from CD, so burned a DVD and tried to install. As per USB all well except the same boot error messages.
  3. Repeated #1 above and then tried using USB boot and selected the option to update 12.04 to 16.04.4 - still got the boot error except this time system completely broke and I was unable to login.
  4. Final attempt was to go for the complete disk erase prior to install - this worked cleanly - so just need to perform a restore of information created using Aptik before I started to perform updates.

So it took a while but I think issues are now all resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.