0

everyone,

I have installed tv13 64bit (teamviewer_13.1.3026_amd64.deb) and this is my first attempt to run teamviewer in linux ever. The OS is ubuntu 14.04 64bit.

there are dependency errors (with Qt5) and I could not see the teamviewer window at all. I "fixed" that by installing Qt5 (5.10.1 to be precise), and starting teamviewer with the following line:

LD_LIBRARY_PATH=/opt/Qt5/5.10.1/gcc_64/lib/ /opt/teamviewer/tv_bin/TeamViewer

you'll notice I start the executable directly from the installation directory.

The teamviewer windows pops up now, but I get this messages in the command line :

failed to get the current screen resources
QXcbConnection: XCB error: 173 (Unknown), sequence: 175, resource id: 87, major code: 150 (Unknown), minor code: 20
WARNING: Application calling GLX 1.3 function "glXCreatePbuffer" when GLX 1.3 is not supported!  This is an application bug!
QSGContext::initialize: stencil buffer support missing, expect rendering errors

Not sure if these are related to my issue though.

Also if I run the usual teamviewer script

LD_LIBRARY_PATH=/opt/Qt5/5.10.1/gcc_64/lib/ /usr/bin/teamviewer

I will get the following output

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process already started (or error)
Launching TeamViewer GUI ...

In both cases the GUI will be loaded and the edit boxes will be disabled because of the error "Not ready. Please check your connection" .

teamviewer 13 in GNU Linux ubuntu 14.04

it may be that the teamviewerd deamon is not running , so I tried starting that as well, but I do not see it running when I check running processes in linux with

ps aux | grep -i teamv

I only see the GUI running.

Anyone knows of any remedies ?

EDIT:

ok I just realized that the teamviewer executable has help menu and it is triggered only by teamviewer help. So I started the daemon with

sudo teamviewer --daemon restart

and I can see it running now. Yet the problem remains.

Thank you in advance for your help

0

I also experienced similar issue with Ubuntu 16.04.4.. However Teamviewer started working normally once I made sure no processes were running and restarted it again. Teamviewer says that 14.04 / LTS should be supported with Qt 5.2 on Ubuntu 14.04 / Debian 8 for the moment. https://community.teamviewer.com/t5/Knowledge-Base/How-to-install-TeamViewer-for-Linux/ta-p/6318

Perhaps try removing or purging Teamviewer 13 and installing from the stable repository? It could be that you have Teamviewer preview -repository enabled, which might have Ubuntu 14.04 incompatible packages.

Installing Teamviewer from the .deb-file downloadable on TV website should add the repositories for Teamviewer in /etc/apt/sources.list.d/teamviewer.list

Currently I have:

        ###   TeamViewer DEB repository list

        ### NOTE: Manual changes to this file
        ###        - prevent it from being updated by TeamViewer package updates
        ###        - will be lost after using the 'teamviewer repo' command
        ###       The original file can be restored with this command:
        ###       cp /opt/teamviewer/tv_bin/script/teamviewer.list /etc/apt/sources.list.d/teamviewer.list
        ###       which has the same effect as 'teamviewer repo default'

        ### NOTE: It is preferred to use the following commands to edit this file:
        ###       teamviewer repo                - show current repository configuration
        ###       teamviewer repo default        - restore default configuration
        ###       teamviewer repo disable        - disable the repository
        ###       teamviewer repo main [stable]  - make all TeamViewer packages available (default)
        ###       teamviewer repo tv13 [stable]  - make TeamViewer 13 packages available
        ###                             stable     omit preview and beta releases


        ### Choose stable main to receive updates for TeamViewer 13 and upcoming major releases
        ### Choose preview main to receive early updates for TeamViewer 13 and to receive major beta releases

        ### Choose stable tv13 to receive updates for TeamViewer 13
        ### Choose preview tv13 to receive early updates for TeamViewer 13

        deb http://linux.teamviewer.com/deb stable main
        #deb http://linux.teamviewer.com/deb preview main

        # deb http://linux.teamviewer.com/deb stable tv13
        # deb http://linux.teamviewer.com/deb preview tv13
|improve this answer|||||
  • I actually do have the Teamviewer 13 preview. Let me check for a stable repository – nass Mar 25 '18 at 19:33
  • hm I cannot find the stable repo for tv 13. on the website the linux version for tv13 is "preview". could you provide a link for a non preview tv13 version ? – nass Mar 25 '18 at 20:09
  • If you've installed TV13 before, there should be sources config for it in.. /etc/apt/sources.list.d/teamviewer.list – rkantos Mar 26 '18 at 13:32
  • I edited my answer to contain the default apt list for TV. (except my comments for getting stable) – rkantos Mar 26 '18 at 13:37
  • Unfortunately even though I have the stable source uncommented as well, The problem persists. Please see my edit though wrt to teamviewerd – nass Mar 26 '18 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.