0

I closed the lid of my laptop, when I opened it, there's no sound from speakers or headphones.

It also happens if I boot Windows and restart to boot Ubuntu. If I shutdown the computer and turn on then boot with Ubuntu and the sound works fine.

I've followed the instructions I could find on askubuntu, and Sound Troubleshooting Procedure yet nothing works. Please help. enter image description here enter image description here

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ sudo echo "options snd-hda-intel model=auto" > /etc/modprobe.d/snd-hda-intel.conf
bash: /etc/modprobe.d/snd-hda-intel.conf: Permission denied

$ sudo lspci -v
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    Subsystem: Hewlett-Packard Company Sunrise Point-H HD Audio
    Flags: bus master, fast devsel, latency 32, IRQ 134
    Memory at a4428000 (64-bit, non-prefetchable) [size=16K]
    Memory at a4410000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [50] Power Management version 3
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
0

1 Answer 1

1

Let me know if it works. The command below will load your snd-hda-intel module by appending it to /etc/modules, you might need to do a log off/log in. echo "snd-hda-intel" | sudo tee -a /etc/modules

7
  • Thanks, @root. That "kind of works". That makes the headphones work but not the speaker for both music on my computer and online (youtube, spotify...)
    – Viet
    Mar 23, 2018 at 3:14
  • You forgot to put your system specs, but anyway, this document may be helpful. Follow the instruction to diagnose the problem and then append the options snd-hda-intel model=YOUR_MODEL to the /etc/modprobe.d/alsa-base.conf file. docs.slackware.com/howtos:hardware:audio_and_snd-hda-intel
    – root
    Mar 23, 2018 at 3:32
  • I've updated the specs above. I've tried with model=ALC295 Analog but permission denied.
    – Viet
    Mar 23, 2018 at 3:38
  • You need root access sudo vim /etc/modprobe.d/alsa-base.conf, then append the options line.
    – root
    Mar 23, 2018 at 3:44
  • It worked, but then I restarted my computer and again there's no speaker sound.
    – Viet
    Mar 23, 2018 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.