15

I have moved house and in my new house my desk, with the computer, is isolated and cannot get the cable fron the router though there is not a big distance, probably 10 meters.

So I dusted off an old dongle I bought for my laptop some time ago, I connected to a free usb 2.0 and everything went smooth I was connected to my wifi in no time, but the max I could get was 5.7 mbps Download and 7.7 upload, this with a 100 mb connection.

I tried a series of ways to get that improved with no success, so finally I decided to buy something to get this improved, first I bought a repeater, but the improve, if any, was neglectable,finally checking in different places I decided to buy a new dongle in Amazon. A wifi adaptor ac1200 with Realtek 8812Au.

It wasn't easy to make it work, my knowledge of Ubuntu is not up to a pro, but finally, following the explanations from a web site (the disk that accompanied the adapter was ALL in chinese!!):

sudo apt-get update
sudo apt-get install linux-headers-generic build-essential git
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd rtl8812AU_8821AU_linux
make
sudo make install
sudo modprobe rtl8812au

It started working right away giving me almost 100 mb, so I was super happy.

After 3 weeks, the adapter didn't start. I have to say the adapter must be connected to a usb 3 and as soon as it is connected there is alight that comes on, well this time not even the light was coming on.

I tried different things:

  • Change the cable to another usb 3 socket, NO SUCCESS
  • Change the usb 3 cable, NO SUCCESS
  • Connect a external drive to the same socket with the same cable,the hdd was working
  • Re-start the computer and try everything again, the same results as before.

So finally I thought that the adapter just had died, as I was still in 30 days Amazon gives you to return the goods, I returned it and, after thinking for a couple of days, I decided to buy it again.

It arrived yesterday, this time the software in the disk was in English, but I thought it would work because the driver was installed, so I plugged it in and ....Oh, surprise!! the light didn't come on, so it doesn't work. I have been reading about this driver and installation in ubuntu this last 48 hours, but most of the places explain what I already did and, to be honest, many of then explain things I don't understand and I am afraid that if it doesn't work I will not be able to undo what I did.

Probably I should delete the driver and do everything again, but I don't know how to do it, or even if that will work.

Any help will be welcome and please, think that I am not a pro with Ubuntu, so make it easy to understand.

Right know I came back to my old dongle with 5.7 mbps right now and if I do a "lsusb" this is what I get:

juan@juan-desktop:~/rtl8812AU_8821AU_linux$ lsusb
Bus 001 Device 005: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 002: ID 145f:013f Trust Megapixel Auto Focus Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 062a:0102 Creative Labs Wireless Keyboard/Mouse Combo [MK1152WC]
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 004: ID 0bda:b812 Realtek Semiconductor Corp. 
Bus 006 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
I am running Ubuntu 16.04 with kernel:
juan@juan-desktop:~/rtl8812AU_8821AU_linux$ uname -r
4.13.0-37-generic

The file in the small cd with the adapter has a zip file called:

RTL88x2BU_WiFi_linux_v5.2.4.1_22719_COEX20170518-4444.20170613.20170427_TV_ANDROID_6.x_COEX_8822BS-C4242_8822BU-C4242(r1)

Thank you in advance for your help.

5
  • 1
    You need to reinstall the drivers whenever there's a kernel update.
    – user692175
    Mar 22 '18 at 21:58
  • do I have to uninstall the "old driver"?
    – Icue
    Mar 22 '18 at 22:00
  • 3
    In fact, your 0bda:b812 Realtek Semiconductor Corp. is an rtl8822bu device, not rtl8812au. I suggest that you edit your question title and try to compile the driver on the CD. If it fails, we'll be happy to assist. Welcome to Ask Ubuntu.
    – chili555
    Mar 22 '18 at 22:02
  • I copied the content of the cd onto my personal folder and opened a terminal in the "Driver" folder, make make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.13.0-37-generic/build M=/home/juan/RTL88x2BU_WiFi_linux_v5.2.4.1_22719_COEX20170518-4444.20170613.20170427_TV_ANDROID_6.x_COEX_8822BS-C4242_8822BU-C4242(r1)/RTL88x2BU_WiFi_linux_v5.2.4.1_22719_COEX20170518-4444.20170613/driver/rtl88x2BU_WiFi_linux_v5.2.4.1_22719.20170613_COEX20170518-4444 modules /bin/sh: 1: Syntax error: "(" unexpected Makefile:1794: fallo en las instrucciones para el objetivo 'modules' make: *** [modules] Error 2
    – Icue
    Mar 22 '18 at 23:51
  • chili555 - Sorry, I have been away for a few days, but still fighting with the adapter to make it work. I have updated the kernel to 4.16.1, and still the same. Tried with kernel 4.13, but no way. I am desperated to make it work.
    – Icue
    Apr 13 '18 at 10:23
19

Randy Ciwyll’s repository has the solution that worked for my system (Linux Mint 18.3 Kernel 4.10). As chili555 guessed, my device is the rtl8822bu. And yes, I have found that I need to reinstall the driver every time I get an applicable update.

sudo apt update
sudo apt install dkms bc git
git clone https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
sudo dkms add ./rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
sudo dkms install -m rtl88x2bu -v 5.3.1
sudo modprobe 88x2bu
6
  • 1
    can you explain the solution by editing your answer (detailled what works in your link) and NB : we are Ubuntu, not Mint ;)
    – damadam
    Aug 21 '18 at 13:29
  • 1
    Thanks! This worked to me for Ubuntu 18
    – Sposmen
    Oct 12 '18 at 1:31
  • Works after Hibernation under Mint 19.2! Anyway to use DKMS to auto configure every kernel update?
    – fleamour
    Sep 8 '19 at 16:14
  • 1
    Also survives kernel updates!!!
    – fleamour
    Sep 22 '19 at 16:46
  • 1
    For Ubuntu 19.10 (5.3.0 kernel), I had to use the newer github.com/cilynx/rtl88x2bu as these instructions were failing. Hope that helps someone!
    – declension
    Oct 27 '19 at 20:19
2

RTL88x2BU-Linux-Driver

Current Driver Version: 5.8.7.2 Support Kernel: 2.6.24 ~ 5.8 (with unofficial patches) in this case xanmod 5.8.11

  1. Clone or Download: https://github.com/RinCat/RTL88x2BU-Linux-Driver.git

  2. Navigate to the downloaded Directory (RTL88x2BU-Linux-Driver) & open in terminal

  3. Compile (build), install & run: with the directory open in terminal, type:

    make (to compile the installer) sudo make install (to install it) sudo modprobe 88x2bu (to start the driver)

Supported Devices

ASUS AC1300 USB-AC55 B1
ASUS U2
Dlink - DWA-181
Dlink - DWA-182
Edimax EW-7822ULC
Edimax EW-7822UTC
NetGear A6150
TP-Link Archer T3U
TP-Link Archer T3U Plus
TP-Link Archer T4U V3
TRENDnet TEW-808UBM
Techkey AC 1200Mbps dual Antenna

And more.

more answers on the .git page.

1

First, install the dependencies:

sudo apt update
sudo apt dist-upgrade
sudo apt-get install linux-headers-generic build-essential dkms git

Next, git clone and install the driver:

git clone "https://github.com/RinCat/RTL88x2BU-Linux-Driver.git" /usr/src/rtl88x2bu-git
sudo sed -i 's/PACKAGE_VERSION="@PKGVER@"/PACKAGE_VERSION="git"/g' /usr/src/rtl88x2bu-git/dkms.conf
sudo dkms add -m rtl88x2bu -v git
sudo dkms autoinstall

Save any unsaved work and then reboot.

After you log back in, run the following command if it shows "no wifi adapter found".

sudo modprobe 88x2bu
3
  • 1
    According to the github page, you probably have to use a USB 2.0 port. See here for more information..
    – mchid
    Aug 30 '21 at 3:15
  • This worked for me. I have Ubuntu Studio 21.04, I had upgraded my internet speed from 50Mb/sec to 100Mb/sec but was only getting 25Mb/sec on my old wireless as it has an old USB wifi adaptor. So I purchased a Simplecom NW621 AC 200 wifi Adaptor with a 5dBi antenna, which should support 5/2.4 GHz dual band. The wifi adaptor came with linux (and windows and Mac) drivers, but the linux driver installation failed and gave errors. I tried @mchid's answer and everything worked perfectly. A speedtest shows a wifi speed close to 100Mb/sec. Sep 8 '21 at 0:00
  • 1
    @StuartAnderson And because the installation uses DKMS, the drivers should automatically update whenever a new kernel is installed so it saves a lot of time and headache in the future.
    – mchid
    Sep 10 '21 at 7:05
0

You could remove your current module with:

sudo rmmod rtl8812au

And then install the provided in the repository:

sudo apt-get install rtl8812au-dkms
1
  • How is rtl8812au-dkms related?
    – Pilot6
    Apr 27 '20 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.