16

"no system tray detected on this system." Appears starting Gnome and Cinnamon in Oneiric 11.10; starting with Gnome Classic and Unity no problem at all. How to solve?

  • Did you install hplip? – Rinzwind Feb 6 '12 at 11:30
  • @Rinzwind: That question deserves some explanation. To my eyes, it seems like it could possibly be meant for another question. :) – Jo-Erlend Schinstad Feb 6 '12 at 12:06
  • Yes, I installed hplip; the problem is not the printer. Some explanation: The full pop-up starting Oneiric-desktop-choice Gnome", or "Cinnamon" is: "No system tray detected on this system. Unable to start, exiting ." – tonwillems.pc Feb 6 '12 at 13:12
  • @ Jo-Erlend Schinstad not if you knew what the problem is ;) – Rinzwind Feb 6 '12 at 13:14
12

In your start up programs there is a line regarding starting hplip. Change ...

sh -c "sleep 15; exec hp-systray"

to

sh -c "sleep 45; exec hp-systray"

and the problem is gone.

hplip is expecting a system tray and that got removed (and was changed into notification area). All this does is postpone startup of hp-systray so if your system is slow to respond this notice might come back and bite you again.

Found it here on Bugzilla (has a fix released on 2011.11.25 (...)). Besides the bug I found the following sources: Linuxquestions, Ubuntuforums

| improve this answer | |
  • Thank ouy Rinzwind for your answer. BUT: where can I find that line in my Start-up programs "sh -c" etc.? I tried Grub, .hplip and the systray-itself,start-up programs. – tonwillems.pc Feb 8 '12 at 14:12
  • Not a problem @tonwillems.pc :) if the answer is what you needed do not forget to accept it ;) – Rinzwind Feb 8 '12 at 14:13
  • BUT: where can I find that line in my Start-up programs "sh -c" etc.? I tried Grub, .hplip and the systray-itself,start-up programs. – tonwillems.pc Feb 8 '12 at 16:00
  • see freecode's comment: askubuntu.com/questions/74031/… – Rinzwind Feb 8 '12 at 16:07
  • Thanks a lot for last link given. Yesterday in my update was a patch for the "no system tray"-issue: I quote:PROPOSED UPDATE..... – tonwillems.pc Feb 14 '12 at 15:03
10

I had this error on every boot on ubuntu 18.04 Bionic Beaver after installing the drivers for my HP printer.

I just deleted the file

/etc/xdg/autostart/hplip-systray.desktop

to get rid of the problem.

| improve this answer | |
  • If you don't want to remove it, changing its extension also works, for example extension old: /etc/xdg/autostart/hplip-systray.desktop.old – alditis Jun 29 at 13:28
6
  1. Go to start up applications using Launcher
  2. Uncheck HP system tray service

enter image description here

| improve this answer | |
  • To bad we can't make it work, though. I was able to restart it and I see the icon, but the icon is not reacting to my clicks... – Alexis Wilke Apr 5 at 18:04
3
sudo apt-get install hplip hplip-gui

will install a newer release of hplip that might fix the issue.

See

for more discussion of the issue

| improve this answer | |
3

note: you can navigate to /etc/xdg/autostart

then look for the file: hplip-systray.desktop

In the meantime open a terminal and login as root.

write in terminal:

sudo rm  hplip-systray.desktop

then drag hplip-systray.desktop file and drop it in terminal and hit enter. That's all.

note: or simply login as root in terminal and write:

sudo rm  /etc/xdg/autostart/hplip-systray.desktop

and hit enter

| improve this answer | |
  • I navigated to /etc/xdg/autostart/ and then ran sudo rm -R hplip-systray.desktop which was by far simpler. No error then appeared on reboot. – User24601 Mar 26 '19 at 19:19
1

Run this command:

sudo apt-get install hplip hplip-gui

When prompted, choose Yes to install new version/release. After installation, reboot your PC/laptop, and you will see HP GUI in your upper right next to your wifi connection icon.

This was tested on Ubuntu 19.04

| improve this answer | |
0

https://forums.linuxmint.com/viewtopic.php?f=208&t=209791&p=1752733#p1752733

I had been using MenuLibre (aka 'Menu Editor') to clean up my xdg applications, as there were a bunch of them in bad state after years of hacking.

(BTW, the Menu bar | Menu Editor | Parsing Error Log command produces a nice list of application desktops that are broken in some way or have other errors.)

So I had edited ~/.local/shared/applications/cinnamon.desktop just to simply give it a better comment, i.e. that if run it would restart cinnamon. (As I can now see, it also starts cinnamon, like initially.)

But MenuLibre had revised it further, and without telling me, and this had broken my ability for Cinnamon's panel and menu to start up. The background was black, and I could only operate on GUI tool, the most recent one, and there were no close buttons on anything. ..

(But, note I could right click on the screen and get a terminal and also I could use Ctl-Alt-F1 to open a tty.)

To find the solution to what had broken I had to restore ~/.local/shared/applications. Then little at a time with divide and conquer I located the file that caused the issue, that is after a whole bunch of painful reboots to test it.

tl;dr: SOLUTION: Restoring this file fixed things:

~/.local/shared/applications/cinnamon.desktop
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.