0

I am having issues with NVIDIA X Server Settings. I will try to put as much info as possible, but if anything is missing let me know and I will add it. I am new to Linux so I might be making mistakes.

Problem: I can select NVIDIA Prime in the settings. The reason I need this is because I have an integrated Intel GPU and an NVIDIA GPU (quadro K1100M). I need to select my NVIDIA in order to work with Driveworks. Samples won't compile with my integrated Intel.

Screenshot NVIDIA X Server Settings

What I have tried so far:

sudo apt purge nvidia*  
sudo reboot  
sudo add-apt-repository ppa:graphics-drivers/ppa 
sudo apt update
sudo apt install nvidia-390 nvidia-prime
sudo reboot

This resolved nothing

sudo apt purge nvidia*  
sudo apt purge cuda*  

And then install Driveworks. This comes with CUDA so should also come with the drivers (I presumed). This did not solve it either.

Select other drivers from the additional drivers tab. I have tried them but they don't solve anything.

My Additional Drivers

sudo apt-get install nvidia-390 nvidia-prime

Also did not work.

In BIOS I changed an option so that it is possible to switch (can't remember exactly what I changed, but there was a graphics card option I had to select). Didn't help either.

My hardware

I hope someone is able to help me further. Thanks in advance.

  • Could you please post text files, dialogue messages, and program output listings as text, not as images? To achieve the latter two you can either 1) select, copy & paste the dialogue text or terminal content or 2) save the program output to a file and use that. Longer listings (the editor will tell you what’s too long) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Mar 22 '18 at 16:55
0

Please install CUDA by following script:

wget http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/cuda-repo-ubuntu1604_9.0.176-1_amd64.deb
dpkg -i cuda-repo-ubuntu1604_9.0.176-1_amd64.deb
apt-key adv --fetch-keys http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/7fa2af80.pub
apt-get update
apt-get install -y cuda-9-0 nvidia-prime
0

What about just trying to install the Nvidia X Server Settings Tool?

sudo apt-get install nvidia-settings
  • Thanks for the suggestion. Output I get: 0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded. – T. Schoonbeek Mar 26 '18 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.