2

ODA Drawings Explorer (formerly Teigha Viewer) is a free (not libre) viewer for proprietary DWG files, developed by Open Design Alliance.

The developing company provides RPM and DEB packages for easy installation at their site.

I download the 64 bit DEB package, and install it using:

sudo dpkg -i TeighaViewer_QT5_lnxX64_4.7dll.deb

After that, the software is easily installed and I can run the software from Dash (windows key + typing Teigha) or from bash with the command

TeighaViewer

The software loads quickly and automatically prompts to open a file. This is where the trouble beings... and ends: the moment I select any DWG, TeighaViewer consistently crashes every time.

  • Regardless if I select big or small DWGs
  • Regardless of the location of the files I select or permissions.
  • Regardless if the DWG file was generated with a new or old version of AutoCAD
  • Regardless if I install the Windows version of Teigha with wine and run it

In all of these cases, Teigha systematically crashes.

I have even tried to open the DWG file directly from command line by issuing:

TeighaViewer myTestFile.dwg

But it still crashes. Note there are no spaces in the name of test DWG file being opened.

When running Teigha from command line, there is a hint of the problem though:

~$ TeighaViewer myTestFile.dwg 
QString::arg: Argument missing: Property Dialog, Teigha Viewer
QString::arg: Argument missing: Property Dialog, Teigha Viewer
terminate called after throwing an instance of 'OdError'
Aborted (core dumped)

I have googled everywhere for these errors, and came empty handed.

Could the be related to missing QT libraries?


My setup:

$ lsb_release -a
Description:    Ubuntu 17.10

$ gnome-shell --version
GNOME Shell 3.26.2

$ uname -a
Linux 4.13.0-36-generic #40-Ubuntu SMP Fri Feb 16 20:07:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

$ cat /proc/cpuinfo | grep model
model       : 142
model name  : Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz

If anyone was able to make TeighaViewer run on Ubuntu, I would like to know their setup (Ubuntu version, 32 or 64 bit, graphics card in use)

  • Make sure all dependencies were installed. Run sudo apt -f install – estibordo Mar 22 '18 at 10:55
  • Use this simple draw github.com/qgis/QGIS/raw/master/tests/testdata/dwg/entities.dwg – estibordo Mar 22 '18 at 10:56
  • There certainly seems to be something wrong with the installer on that application because when I tried, it couldn't even find its own shared objects. As a possible alternative, there is a DWG application available from 3DS for Ubuntu (although its still in beta) and it is available here. I've tried it in the past and it seemed to work well. – gsxruk Mar 22 '18 at 19:34
  • @estibordo Nothing else is installed with that command. System is 100% up to date. The test DWG file also crashes Teigha upon loading. Does this indicate anything in particular? – chronos00 Apr 16 '18 at 13:09
0

ODA Drawings Explorer

To install ODA Drawings Explorer (formerly known as Teigha Viewer, freeware but not free nor open source software):

  • Go to their download page
  • Download "ODA File Converter for Linux 64-bit (DEB)" (or 32 if it is your case)
  • Install dependency

    sudo apt install qt5-default
    
  • Install the package

    sudo dpkg -i ODADrawingsExplorer_QT5_lnxX64_4.7dll.deb
    
  • This will install odadrawingsexplorer package and /usr/bin/ODADrawingsExplorer GUI app.

screenshot

ODA File Converter

For ODA File Converter (formerly known as Teigha File Converter):

Same as above but with it will install odafileconverter and /usr/bin/ODAFileConverter GUI app.

DWG converter on FreeCAD

To install and add the DWG converter to FreeCAD:

sudo add-apt-repository ppa:freecad-maintainers/freecad-stable # Last stable
sudo apt install freecad

screenshot

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.