3

I recently swapped out the wireless card in my Dell XPS 15 for a shiny new Intel 9260. I'm running Ubuntu 17.10 on the Mainline 4.15.12 kernel, alongside a dual-booted Windows 10. The card works exactly as advertised in Windows 10, and I can usually get a stable 300mbps up, 200mbps down.

Intel insists this card should work on any new linux kernel since 4.14, and they're kind of right. Everything works great except for one little problem. Download speed.

I have the latest intel microcode for this chip (34.0) and have confirmed with nmcli that it is being loaded.

I've tried some basic fixes for ubuntu wireless trouble, but the only thing that improves my speeds at all so far is disabling 11n mode entirely via adding "11n_disable=1" in iwlwifi.conf. This also kind of works; it's more stable, but restricts me to significantly slower speeds, so i'd prefer to avoid this solution.

I also ran the Ubuntu Forum's wireless info script, uploaded here if it may help in diagnosing the problem.

Does anyone know what might be going on? How is my upload speed so smooth, when the download moves like grass grows? Should I just wait for 18.04 LTS?

1

Your wireless info report shows that you are connected to the SSID Syntive. There are no less than four instances of Syntive within scan range. We suspect we'd also see, in your message log, that the wireless disconnects to roam to another instance of Syntive hoping for a better connection. Sounds like my old girlfriend!

Unfortunately, you are connected to an instance at 67% signal strength when another instance is available at 89%. I suggest that you scan and find the MAC address of the instance with the highest signal strength and bind Network Manager to it like this: Ubuntu connect drops. Worked for a while then started dropping again

I'd also experiment binding NM to the srongest 5 gHz instance. My Intel 7260 is remarkably faster, as you'd expect, connected at N and AC speeds.

Then set your regulatory domain explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

EDIT: Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

  • Thanks for the comment chili555! My regulatory domain is already set to US, so that seems to not be the problem. Additionally, I understand why there are four Syntives, although it's less than ideal... two access points, each of which has a 2.4ghz band and a 5ghz band. After plopping my laptop down right next to the AP i'm connected to, I ran the tests again and saw the same strange result: .5mbps download speed, several hundred mbps upload. Weird! I then also tried adding the AP's mac address to prevent it from roaming, but this did not help either. – Ian Klug Mar 21 '18 at 22:35
  • Are they yours? Can they be renamed? Syntive2.4, Syntive5, etc.? – chili555 Mar 21 '18 at 22:37
  • Ooh, good idea! I will check my router settings and see if setting them to individual 2.4ghz and 5ghz bands is an option. – Ian Klug Mar 21 '18 at 22:39
  • Unfortunately my router, a Netgear Orbi, seems to be resistant to setting each band to a separate SSID. If I bound my connection in the OS to the mac address (BSSID) of the 5ghz band on the closer AP, wouldn't it exclusively use that one? – Ian Klug Mar 21 '18 at 22:47
  • It surely should. I will edit my answer to add some router suggestions as well. – chili555 Mar 21 '18 at 22:48
1

Update for anyone watching: Today the problem sorted itself out when I installed kernel 4.16.0 mainline, which shipped with a microcode update.

For usable speeds in a pinch on a kernel <4.16, setting "11n_disable=1" in iwlwifi.conf works alright, but it seems that full speed with my 9-series card on this hardware (XPS 15 9560) requires the new kernel. Sometimes it's hard living on the bleeding edge.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.