2

When I try to install postgresql i get the following error:

sudo apt-get install postgresql-client


Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Breaks: gcc-4.4 (< 4.4.6-4) but 4.4.4-14 ubuntu5 is to be installed
E: Broken packages

How do I resolve this issue to install postgresql?

1
2

Try removing gcc and install it again:

$ sudo apt-get remove gcc g++
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install build-essential
$ gcc -v

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.