I am having Ubuntu 16.06LTS and Hp pavilion laptop. And not able to start Wi-Fi. I have used many solutions which are already given on the forum like, 1. rfkill unblock all 2. Removing /dev/rfkill and restarting But none of them worked.

rfkill list shows below output, 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes

Thanks in advance

  • What wifi card is this and what driver are you currently using for it? – sbergeron Mar 21 '18 at 17:28
  • Wifi card Ralink Corp. RT3290 wireless 802.11n 1T/1R PCIe – Ruturaj Bisure Mar 21 '18 at 17:32
  • Is the Wifi Interface being managed by NetworkManager? – tstrike Mar 21 '18 at 17:32
  • In setting -> network then Airplane mode is already on.. If I off it and close tab and reopen, then again it change to ON status automatically.. And wireless on off button is not working – Ruturaj Bisure Mar 21 '18 at 17:34

HP laptops use a module hp-wmi to translate key presses into action; in your case, turn off the hard block and turn on the wireless.

Let’s troubleshoot your problem.

First, check to see if the module hp-wmi is loaded.

lsmod | grep hp

If so, remove it:

sudo modprobe -r hp-wmi
sudo rfkill unblock all
rfkill list all

Any improvement?

| improve this answer | |
  • Sorry for late comment. It is still showing the same error – Ruturaj Bisure Mar 22 '18 at 15:34
  • Any further suggestion? – Ruturaj Bisure Mar 22 '18 at 17:01
  • Please see my answer and the following comments here: askubuntu.com/questions/983565/… Aside from trying the daily build of Ubuntu 18.04 to see if the bug in hp-wmi is resolved, I haven't any other suggestions. Sorry. – chili555 Mar 22 '18 at 20:02
  • I have reset the BIOS and it had started, but after 5 mins the problem started again. – Ruturaj Bisure Mar 25 '18 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.