0

During software update (though Ubuntu Software Updater) in Ubuntu 16.04, suddenly the GNU GRUB screen appeared. It could not find the linux installation anymore. Following the suggestions from [1], I used 'ls' to find out where my ubuntu kernel was located: partition (hd0,2). There were many different versions there, although more vmlinuz than initrd. Since you need to have both of the same version to boot, I used the latest version for which both files were present: vmlinuz-4.4.0-108-generic and initrd.img-4.4.0-108-generic. Using the following commands

grub> set root=(hd0,2)
grub> linux /boot/vmlinuz-4.4.0-108-generic root=/dev/sda2
grub> initrd /boot/initrd.img-4.4.0-108-generic
grub> boot

I could boot my ubuntu installation. However, after login I would get a black screen. I could login to tty1 though, so following suggestions from [2] I tried running

sudo dpkg --configure -a

but this gave an error message. Then I found various posts indicating that the 108 kernel was problematic, so instead I redid the above steps in GRUB to boot the second-latest kernel, 4.4.0-97-generic. Then also dpkg --configure -a ran without any problems and generated the missing initrd images. I updated all packages with

sudo apt-get update
sudo apt-get upgrade

Then, upon reboot, GRUB could find my installation again (now version 116)!

So that's already something. However, I still get a black screen after login, which seems to be a problem with the display manager. The software is fully up-to-date now, dpkg --configure has done all it has to do, but somehow there is an issue while starting up lightdm. Following [3], I tried to install a different display manager, gdm3, but this resulted in a similar issue: instead of a black screen after login, I was simply returned to the login screen, so I still couldn't get in. I concluded it's not a lightdm issue.

As suggested in [4], I tried purging all xserver files, lightdm and plymouth, the reinstalling all, and eventually also ubuntu-desktop. This didn't resolve the black screen, so again I ran:

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade -y

which upgraded some packages. But after rebooting still no luck.

Then, after reading [5], I checked the .Xauthority file and /tmp directory and all was as it should be. I also tried logging in as a guest user, but this still lead to a black screen.

So I looked into the lightdm logs at /var/log/lightdm/:

  • lightdm.log doesn't show any errors

  • x-0.log shows a warning: The XKEYBOARD keymap compiler (XKBcomp) reports: Warning: 'Type "ONE_LEVEL" has 1 levels, but has 2 symbols. Ignoring extra symbols. Errors from xkbcomp are not fatal to the X server.

  • seat0-greeter.log is empty, but seat0-greeter.log.1.gz is full of warnings, the first being: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

If I manually try to startup lightdm in debug mode by typing lightdm --debug --test-mode it says "Failed to get D-Bus connection".

After login, I still get a black screen and it tells me 'System program problem detected'. I'm out of inspiration, any help would be greatly appreciated!


System information: I'm running Ubuntu 16.04 LTS on an HP laptop with Intel core i7 processor and AMD graphics card.

lspci -vk | grep -iA15 vga shows me:

VGA comptible controller: Advanced Mircro Devices, Inc. [AMD/ATI] Chelsea XT GL [FirePro M4000] (prog-if 00 [VGA controller]) ... Kernel driver in use: radeon Kernel modules: radeon


[1] After update in Ubuntu 16.04 I ended up in GNU GRUB and appear to be stuck there

[2] Ubuntu 16.04 LTS black screen after login

[3] https://wiki.ubuntu.com/LightDM#Help.2C_I_can.27t_see_my_Desktop.21

[4] http://helewix.com/howto/ubuntu-17-10-black-screen-solution/

[5] Ubuntu gets stuck in a login loop

0

Today an update caused similar symptoms on my HTPC, which is an Intel NUC box running 16.04 LTS.

I could reach my Ubuntu box via VNC but my TV display via HDMI was always black.

I am working ok now after the following steps:

xrandr -q (to see my HDMI connections are not detected)

Tested my TV and HDMI cable with a laptop, all good. Update my way past the issue

apt-get update
apt-get upgrade

The Update forward did not fix it, time to roll back... What kernel package is the latest we are using?

dpkg --list | grep linux-image | more

It is 4.4.0-119 so lets get rid of it:

apt-get purge linux-image-4.4.0-119-generic
apt-get purge linux-headers-4.4.0-119-generic

Reboot to check

shutdown -r now

What is the current kernel we rolled back to?

uname -a

OK lets see if 4.4.0-97 fixed it?

xrandr -q

Nope, no HDMI still. Lets make sure are packages are OK

dpkg --configure -a

Lets try update and upgrade again...

apt-get update
apt-get upgrade

Lets try a full power down

shutdown -h now

Now lets watch the BIOS screen come up on the TV when we power the NUC box on. BIOS displays and Ubuntu is back on my TV.

The kernel I landed on that is working now is: 4.4.0-116-generic

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.