I am trying to install git on Ubuntu 16.04 LTS but every time I get this message. I have already uninstalled libpcre2-8-0, and synaptic shows nothing in broken packages. It shows only when I mark git-core package to install, and I don't know what to do after.

$ sudo apt install git
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 git : Depends: libpcre2-8-0 (>= 10.22) but 10.21-1 is to be installed
E: Unable to correct problems, you have held broken packages.

marked as duplicate by karel, wjandrea, Community Mar 19 '18 at 18:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Simple solution use synaptic.

What you could try

sudo apt install libpcre2-8-0 

Otherwise get synaptic if possible and try to install git through it. It's a front end application for apt. Try to install it with apt. If issues occur, get the packages from here https://packages.ubuntu.com/xenial/

dpkg -i ~/Downloads/'package name'

This will also give you the output if you need anything else.

  • Thank you man, downloading the packages and dpking works here – Vehns Mar 19 '18 at 18:42
  • Awesome glad I could help you. :) – Joeri_Damian Mar 19 '18 at 18:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.