0

I am trying to install Lollypop on a new Linux install 16.04 LTS. When I run

sudo apt-get install lollypop

I get the error 'file not found'. (Yes, I added the repo)

I found a deb package online and installed that but Lollypop would run for a second then close.

Can't find any info on this problem after looking for a couple of hours. Any ideas?

The original info I used to install Lollypop I found here. I found the Xenial package here and installed using GDebi.

7
  • 1
    The first thing to figure out that kind of error is to run lollypop from the command line and see what error messages you get.
    – Jos
    Mar 19 '18 at 10:17
  • Lollypop : launchpad.net/~gnumdk/+archive/ubuntu/lollypop ... Or install the downloaded package : cd Downloads/ && sudo gdebi ./lollypop_*_amd64.deb Mar 19 '18 at 12:48
  • Sorry that was not a great post. Yes - sudo apt-get install lollypop The error I get is: E:unable to locate package Mar 19 '18 at 18:28
  • Sorry that was not a great post. Yes - sudo apt-get install lollypop was the command I used. Yes - did run sudo apt-get update (upgrade as well). The repository is hit when I run update. The error I get is: E:unable to locate package lollypop. Can't run Lollypop from command line. I went to the site that Knud Larsen posted - I cannot find a package for Xenial Thanks Mar 19 '18 at 18:41
  • 1
    also, I could not find the xenial package in the ppa that is in the instructions I found on the web. - ppa:gnumdk/lollypop Mar 22 '18 at 18:39
3

Running lollypop from the CLI gives an error that GTK+ 3.20 is needed, the current installed version was 3.18.
A way to upgrade 3.18 to 3.20 can be found here.
Adding two repos by the following commands and updating should trigger a bunch of packages that needed to be updated. Note that you'll be installing untested packages and if you intend to switch between Unity and GNOME you should expect some compromise on the Unity half.

sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo add-apt-repository ppa:gnome3-team/gnome3

Reboot and Lollypop should be running now.

1
  • If this solves your problem, you may "accept" it (by clicking on the tick mark (✓) next to it) so others may more easily find it in the future. Accepting your own answer is completely fine :)
    – pomsky
    Mar 25 '18 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.