Greetings everybody,

My question here is related with running Ardour and Mixbus. I've recently bought a Behringer's UMC404HD. Differently from what I've seen around, Jack recognizes the interface, Alsa Mixer too (altough it is not on the top of the list). I can see the device under Alsa Mixer etc. I can start Jack and make all adjustments, but when I load either Ardour or MixBus, starts but sytem becomes quite unstable, no sound etc. I have tried many things (e.g. running MixBus under Alsa>Jack etc.) But it doesn't work at all. I've tried the Unity under Windows and it runs fine. While Installing MixBus I've got couple messages regarding processor scaling systems governor to be set as " performance" which I did (I'll try to load pics here).

enter image description here

But despite all the adjustments done, seems that the system and the interface are not getting along too well... Most the time MixBus doesn't run at all... but even when I make it work, I can't record, play anything. Same with Ardour.

I've installed 17.10 then formated the HD and installed 16.04 and in both systems I could not make MB nor Ardour to run.

Well I hope I have provided engough information. I don't know if it is an ALSA, OR the Interface problem (Behringer says that it is USB compliant and runs OTB with Mac OS) but did not work for me at all.

Please let me know If I need to provide more info ok?

Thank you for your attention.


After this problem, I've found the 'LinuxMusicians' forum. and there, I was able to understand what was going on.

They told me to install the script "realtimeconfigquickscan".
It's a very nice script that you install which displays what is preventing your system to work properly with professional audio (my case).
From that time on, I've been working on perfecting its use. Here's how to do it:

git clone git://github.com/raboof/realtimeconfigquickscan.git
cd realtimeconfigquickscan
perl ./realTimeConfigQuickScan.pl

The site from where I've got the info is LinuxAudio.
I strongly advise to read the whole contents of the page.

We are now working to make a .deb file that will do all of these instructions at once.
We have made tests and it's 80% working properly without crashing or anything.

Pretty soon we'll make it available for everyone and leave the open code to people for improvements.


I've had no problems running Ardour with UMC404HD in 64-bit 16.04. However, I had to resort to jack. Try starting jack with jackd -d alsa -d hw:1 -r 192000 but firtst check your card number with aplay -l and then start Ardour What I cannot do: 1. Ardour just works at 48kHz not at 192kHz as Audacity direct to Alsa 2. Neither Ardour or Alsa can access more than a stereo channel, there are 4 inputs in this device. Ah, don't forget to add yourself to the system audio group. I hope this helps.

  • What version of Ardour are you running? I'v got 5.12 up, and it runs 192kHz - I use a Behringer XR18 which is limited to 48 kHz, and another Behringer 4 port which does run 192... – Charles Green Jan 31 '19 at 23:30
  • I am resorting to jack as well with Ardour v5.12.0. I don't have to do anything such as starting jack manually. It works at 192k 4-channel but there are few but still existing dropouts, so I use it at 96k flawlessly. 16.04 64-bit as well on a laptop. Check if this helps: ajoliveira.com/images/audio/ardour01.png – Antonio J. de Oliveira Feb 2 '19 at 9:36
  • Very cool - my 18 port Behringer also suffers dropouts at 48 kHz - I think my laptop simply cannot keep up at times. My solution has been to disable the swap, and add some extra buffer... – Charles Green Feb 2 '19 at 16:04
  • I also added at the end of /etc/pulse/daemon.conf ; ajoliveira resample-method = src-sinc-medium-quality default-sample-format = s24le default-sample-rate = 192000 alternate-sample-rate = 192000 default-sample-channels = 4 default-channel-map = front-left,front-right,rear-left,rear-right – Antonio J. de Oliveira Feb 4 '19 at 8:47
  • To validate the settings you may use: pacmd list-sinks | grep sample less /proc/asound/card0/pcm0p/sub0/hw_params – Antonio J. de Oliveira Feb 4 '19 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.