1

When I am typing I want to be able to use the compose key to get at "dead" characters, if I press the compose key simultaneously with the key I want I can toggle dead mode, for the next key I press.

however, if I press the compose key alone, all subsequent keypresses give me their level 2 symbols. I don't know how to go back to normal key symbols... this compose mode seems to be locked on forever.

As an example in below, the first line is typed "123..." then I press alt-gr by itself... then I type "123..." again but now I get all the compose versions and not the normal numbers. (this is a French keyboard in this example)

example...

normal typing 1234567890 gives me 1234567890

I press alt-gr once then 1234567890... gives me &é"'(-è_çà

now the only way to go back to 1,2,3,4,5 etc is to press shift+1 etc

The keyboard is locked into the compose mode and I need to restart to get it out of this mode, (or change it to a different language).

to be clear, it seems that on my keyboard entering this "compose mode" is a permanent effect, and lasts for longer than just the subsequent keypresses, I want it to turn off after the next keypress.

8
  • if your familiar with the concept of compose keys, imagine a mode where all key presses register as there compose variations, with no access to the non-compose versions – joe Lovick Mar 18 '18 at 22:19
  • Your question and comments confuse me. Can you please edit your question and let us know exactly which keyboard layout you are using and provide a few specific characters which you can't type successfully as expected. I think it would be easier to guide you with that information. – Gunnar Hjalmarsson Mar 19 '18 at 14:55
  • I appreciate your help, i tried to rewrite the question to better explain – joe Lovick Mar 19 '18 at 15:05
  • From your latest description, it appears to me as if it switches to some other keyboard layout. Have you possibly defined <AltGr> as a shortcut for switching layouts? – Gunnar Hjalmarsson Mar 19 '18 at 15:30
  • not knowingly, how would i establish this? – joe Lovick Mar 19 '18 at 15:31
3

If you have defined AltGr as a compose key, its original behavior is overridden.

To disable the compose key, and with that retain the original behavior of AltGr, you can use Tweaks (gnome-tweak-tool) or run this terminal command:

gsettings reset org.gnome.desktop.input-sources xkb-options
1
  • 1
    so I have reset all bindings, and it doesn't help, it appears this is a feature by design, see pomsky's answer, I just need the Alt-GR to only impact the next character, not all subsequent characters. – joe Lovick Mar 19 '18 at 14:29
1

This seems to be the default behaviour of the French keyboard.

enter image description here

As per the keyboard layout above, if you press 12...90, you're supposed to get

&é"'(-è_çà

If you press Shift+12...90 instead, you should get

1234567890

So "pressing Shift+Alt-Gr" part seems to be a red herring.

3
  • OK, i can buy that... it behaves as you describe.. how do i turn it off when it is on so that i can go back to getting 1 to be 1... ideally pressing the Alt-Gr would only work on the next keypress, like it does on the mac – joe Lovick Mar 19 '18 at 14:24
  • See Gunnar's answer. – pomsky Mar 19 '18 at 14:28
  • unfortunatly that doesnt solve the problem. i do need to get at compose characters, i just need to be switch back to normal characters after i have typed one. – joe Lovick Mar 19 '18 at 14:36
1

The problem was caused by a custom keyboard layout that had an issue, disabling this keyboard layout and restarting my machine, stopped the problem on other keyboard layouts.

I now need to find the problem with this keyboard layout, but that as they say is a different problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.