0

I have a dual boot system and new ubuntu LTS 18.04 is releasing next month so I want to upgrade my system from 14.04 to 18.04. The best way for the up-gradation is first by going to 16.04 and then to 18.04. Today I upgraded my system from 14.04 to 16.04 and everything seems to work fine but in the middle of the installation of update my system completely freezed and I was forced to restart the system.

After the restart when I went to ubuntu it got stuck in the startup itself

enter image description here

After that I went to advance option for ubuntu > recovery mode where I login to my system in terminal using my username and password. Firstly I tried lsb_releas -a command and it confirmed that I have ubuntu 16.04

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.x LTS
Release:    16.04
Codename:   xenial

I then did an apt-get update but it returned a relocation error which I solved using this answer (had to install both amd6 and i386 files) by downloading the files using the second windows OS. Then I checked my internet connection using ping -c 1 google.com which returned Unknown host error. Without internet I cant solve or download any files in my ubuntu. If I have a connection to web in this terminal only ubuntu 16.04 I can definitely solve my other problems. Any idea how to solve this?

After this debacle I am withholding my up-gradation to 18.04. I now want to properly install 16.04

P.S. I dont remember what I did but I have seen Networkmanger is not running error in my ubuntu 16.04

if it help my rfkill list all looks similar to this

0: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: dell-wwan: Wireless WAN
Soft blocked: no
Hard blocked: no

3: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no

EDIT

Due to some circumstanceses I cant do a fresh install this forced me to correct my upgradation problems. So I was able to gain my desktop back with new 16.04 and internet back by doing these commands

sudo dpkg --configure -a
#kept all intemediary prompts in default option ie "N"
#After this restart the systemn

Then I restarted the system, this brought back my internet connection and in recovery mode terminal did

sudo apt-get update
sudo apt-get upgrade #not working shows error
sudo apt-get install -f #not working shows error
sudo dpkg --configure -a

Restarted it again now it brought back my desktop but when now my apt-get is not working (internet is fine).

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 click : Depends: python3-click (= 0.4.21.1ubuntu0.2) but 6.2-2ubuntu1 is installed
 click-apparmor : Depends: python3-apparmor-click (= 0.2ubuntu1) but 0.3.13.1 is installed
 cpp-5 : Depends: gcc-5-base (= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
 g++-5 : Depends: gcc-5-base (= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
 gcc-5 : Depends: gcc-5-base (= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
 libasan2 : Depends: gcc-5-base (= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
 libavformat-dev : Depends: libavcodec-dev (= 7:2.8.11-0ubuntu0.16.04.1) but 6:9.20-0ubuntu0.14.04.2+fdkaac is installed
                   Depends: libavutil-dev (= 7:2.8.11-0ubuntu0.16.04.1) but 6:9.20-0ubuntu0.14.04.2+fdkaac is installed
                   Depends: libswresample-dev (= 7:2.8.11-0ubuntu0.16.04.1) but it is not installed
 libboost-context-dev : Depends: libboost-context1.54-dev but it is not installable
 libboost-dev : Depends: libboost1.54-dev but it is not installable
 libboost-serialization-dev : Depends: libboost-serialization1.54-dev but it is not installable
 libgcc-5-dev : Depends: gcc-5-base (= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
 libmpx0 : Depends: gcc-5-base (= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
 libproxy-tools : Depends: libproxy1 (>= 0.4.7) but it is not installable
 libproxy1-plugin-gsettings : Depends: libproxy1 (= 0.4.11-0ubuntu4) but it is not installable
 libproxy1-plugin-networkmanager : Depends: libproxy1 (= 0.4.11-0ubuntu4) but it is not installable
 libstdc++-5-dev : Depends: gcc-5-base (= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
                   Depends: libstdc++6 (>= 5.4.1-2ubuntu1~14.04) but 5.4.0-6ubuntu1~16.04.9 is installed
 libswscale-dev : Depends: libavutil-dev (= 7:2.8.11-0ubuntu0.16.04.1) but 6:9.20-0ubuntu0.14.04.2+fdkaac is installed
 libwebkitgtk-1.0-0 : Depends: libjavascriptcoregtk-1.0-0 (= 2.4.11-0ubuntu0.1) but 2.4.10-0ubuntu0.14.04.1 is installed
                      Depends: libwebkitgtk-1.0-common (>= 2.4.11) but 2.4.10-0ubuntu0.14.04.1 is installed
 python-kivy : Depends: python-gst-1.0 but it is not installed
               Depends: libsdl2-image-2.0-0 (>= 2.0.0) but it is not installed
               Depends: libsdl2-mixer-2.0-0 (>= 2.0.0) but it is not installed
               Depends: libsdl2-ttf-2.0-0 (>= 2.0.0) but it is not installed
E: Unmet dependencies. Try using -f.

I again did sudo dpkg --configure -a which showed me these errors

Errors were encountered while processing:
 python-kivy
 libswscale-dev:amd64
 libwebkitgtk-1.0-0:amd64
 libavformat-dev:amd64
 libunity-scopes1.0:amd64
 unity-scope-mediascanner2
 unity-scope-scopes

It seems I have non compatable python-kivy so I tried to purge pyton-kivy

sudo apt-get purge python-kivy
sudo apt-get remove python-kivy

but again it shows Unmet dependencies error. My apt-get is not working at all cant install or uninstall apps.any idea how to solve this

  • 4
    There are so many changes between even 16.04 and 18.04 I would do a fresh install, let alone try to upgrade from 14.04 . IMHO it takes longer to debug failed upgrades than a fresh install and I would almost advise you try 18.04 beta on a live iso and install it if it looks good. At this point you do not have much to loose by doing so. – Panther Mar 18 '18 at 16:31
  • any idea how to get back my internet back.. any links? – Eka Mar 18 '18 at 16:37
  • Identify your wireless card and google search the chip – Panther Mar 18 '18 at 16:43
0

I successfully upgraded to 16.04 after my botched upgradation. I have solved unmet dependency error by changing the server to a better one.The other problems I solved by finding solution for every single error. Its better to search those error in the internet and use the recommended solutions. I also manually downloaded package files and installed using dpkg. These are the important commands which helped me to solve my problem

#(Not in any order)
sudo dpkg --configure -a #this is an important command 
sudo apt-get update
sudo apt-get install -f #this is an important command 
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo apt-get autoclean
sudo dpkg -i <package name>

#this last one I used after solving my desktop and internet problems
sudo update-manager -d

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.