2

I'm trying to record sound from my piano which only has 'headphones' audio output (as well as loudspeakers), so there is no USB for things like MIDI. Thus I connect the piano to my computer using a double jack cable.

I tried to record with Audacity, but I'm not able to get any sound to my computer through the jack cable : at first I only had pulse (and default) as input sources.

I installed pulseaudio-module-jack but that didn't help. Then I installed Ardour5 (that doesn't work at all, but that's not the point of this question) which automatically installed qjackctl, but the only way I found to launch JACK was to change the default configuration : I had to change the Input and Output devices from (default) to hw:PCH.

So now I can select JACK Audio Connection Kit instead of ALSA in Audacity, but the input sources either are system, which gives nothing else than the built-in microphone output, or PulseAudio JACK Sink, which doesn't work at all (Audacity only shows a flat line).

Is there something wrong with how I configured qjackctl ? Or is there any other tool to record audio from the jack ?

Notes :

  • I tried this, but without success ;
  • I'm talking here about inputs shown in Audacity, but I checked the Input section under Settings > Sound, as well as PulseAudio Volume Control, there were no other sources.
7
  • To be honest, if you are doing recording, it is best to use a specialized distro. I use kxstudio - kxstudio.linuxaudio.org . you can try ubuntu studio as an alternate. Audacity never worked well for what you are doing, use Ardour – Panther Mar 18 '18 at 16:29
  • 1
    Does your laptop have a dedicated "Microphone" connector ? - you need to go from piano to that, as simply connecting two heaphone outputs won't work. If your laptop doesn't have a microphone input, you'll need to get a TRRS adapter like this one (mono only, may give bad sound quality), or a USB sound card (better). – JonasCz Mar 18 '18 at 16:35
  • @Panther I'll try a specific distro, thanks for the advice. It might be that Audacity isn't the best thing to do that, but it's not the issue here (I updated the question explaining that I checked the Input sources in the Settings as well) – N. Cornet Mar 18 '18 at 16:43
  • @JonasCz My laptop has a combined microphone/headphones jack (female) connector. (There is a logo of both headphones and microphone under the connector, and when I connect a headset with microphone, the headset microphone works) – N. Cornet Mar 18 '18 at 16:48
  • After my experience with audio recording I would not try to debug or tune a standard Ubuntu install for what you are doing. The AV specific distros have all the tuning out of the box, including jack so kxstudio may solve your problem . – Panther Mar 18 '18 at 17:07
1

So - there's an oddity in Ardour: If you have jackd running in an attempt to use realtime mode, Ardour will fail. And if you start jack from Ardour, Ardour will always try to start with realtime mode enabled...

The solution to this is to force jackd to start without realime enabled. The easy way to do this, is to use qjackctl and in it's setup, un-check the realtime mode checkbox:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.