1

Tried to add fcitx-mozc module to input Japanese on 17.10

apt install fcitx-mozc

then set the input method to fcitx ▾

But for some reason "日本語 Mozc" does not appear in the Input Sources (Text Entry).
(this after trying several times, rebooting in between)

It seems being on 17.10 makes a difference.

Is there another module to install? Or maybe 17.10 does not support fcitx-mozc?

4
  • Did you try to follow instructions posted here askubuntu.com/questions/791834/… Commented Mar 18, 2018 at 16:18
  • This is one of the page I was using ... Did install Japanese anthy on 16.04 in the past and had no problem. This is for a Japanese friend who wants fcitx-mozc.
    – Déjà vu
    Commented Mar 18, 2018 at 16:21
  • @JacekHerbrych: Those instructions seem to be obsolete for Ubuntu 17.10. Commented Mar 18, 2018 at 17:04
  • Try 16.04.4 LTS + fcitx-mozc. Xubuntu 17.10 + fcitx-mozc. or 17.10 unity (Ubuntu desktop) + ibus-mozc. Commented Mar 19, 2018 at 7:59

1 Answer 1

2

Ubuntu 17.10 is based on GNOME, and GNOME doesn't support Fcitx well. Unless your friend is using the Unity desktop, it's probably wise to advise them to install and use ibus-mozc instead.

(There is no "Text Entry" on your friend's 17.10, right?)

Edit:

Otherwise, to use fcitx-mozc on Ubuntu 17.10 with GNOME, it can be enabled from the Fcitx Config Tool. Not sure how well it works, though. If fcitx-mozc is considered important, your friend may want to switch to a non-GNOME desktop environment.

2
  • Thanks but ibus-mozc was installed already (default, probably), and there is no added Japanese "input source" that could be used, then. What would be the next step?
    – Déjà vu
    Commented Mar 19, 2018 at 8:30
  • @RingØ: See my edited answer. Commented Mar 19, 2018 at 13:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .