1

I have 17.10, been using gnome-flashback for quite a long time, since 16.04 and kept upgrading.

After installing latest updates, I can't make gnome-flashback to appear. In the login screen, I can choose Gnome Flashback - Metacity or Gnome Flashback - Compiz, but both, when chosen, end up displaying the new layout with "Activities" and the large icons panel on the left.

I have tried reinstalling gnome-flashback using

sudo apt-cache depends gnome-flashback | \
grep '[ |]Depends: [^<]' | cut -d: -f2 | tr -d ' ' | \
xargs sudo apt-get --reinstall install -y

which finished, but after restart, I still end up in that weird layout.
Also, when I lock the screen, it behaves like something was pressing enter every ~500ms, so it's not possible to enter the password.

What happened? Is that a bug? Is Gnome Flashback supposed to work? What should I try to get it back? Thanks!

Update: After reinstallation of gnome-flashback, some GTK apps wouldn't start, e.g. Synaptic said:

$ sudo synaptic
Invalid MIT-MAGIC-COOKIE-1 keyUnable to init server: Could not connect: Connection refused
(synaptic:3867): Gtk-WARNING **: cannot open display: :0

I was able to solve it as per this. I think I had this issue after upgrading to 17.10. Not sure if it is related to my issue above.

  • Yes, GNOME Flashback is supposed to work! Have you tried to create new user? If not try that to make sure it is not some configuration problem with your user. Otherwise have you checked log files? – muktupavels Mar 24 '18 at 12:13
  • Haven't tried other user. I have checked dmesg. Which other would apply? – Ondra Žižka Mar 26 '18 at 23:48
0

"when I lock the screen, it behaves like something was pressing enter every ~500ms, so it's not possible to enter the password"

I was able to fix this by uninstalling lightdm and gdm3, and then reinstalling both, and running sudo dpkg-reconfigure lightdm which took me to a dialog where I chose lightdm over gdm3 (which was used before). Now I am at least able to lock and unlock the system. Still no Flashback though.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.