3

Ctrl + Alt + b key combination is being hijacked on Ubuntu 16.04 Xenial.

When I press it in different programs it performs some weird hard to explain actions. One of the things it does is to remove the caret in a text area...

I've checked both "System setting > keyboard > Shortcuts" and compiz config manager and the shortcut key doesn't exist in either.

How can I disable this key combination so that I can use its functionality on Intellij?

2
  • You may check where this shortcut was set with commands gsettings list-recursively | grep -i ctrl | grep -i alt | grep -i b and dconf dump / | grep -i ctrl | grep -i alt | grep -i b. On clean xenial I do not have ctrl+alt+b defined. – N0rbert Mar 18 '18 at 14:32
  • I ran your commands and I don't have it defined either. But you can click on any text box and press it to see the effects. I checked this on a friend's computer as well. Its not the effect that I care about; but the fact that Intellij doesn't detect the combination when pressed. Whereas it does detect any other combination that I've tried. – raven Mar 19 '18 at 11:53
2

Sorry, I don't have direct answer.

If you are in Unity environment. All the keyboard shortcuts are stored in System setting > keyboard > Shortcuts (tab).

You can find all the custom shortcut in "Custom Shortcuts (tab)".

enter image description here

You can add or edit any shortcut keys here.

To know how to edit shortcut keys, refer the below article:

How to change keyboard shortcuts?

6
  • I forgot to mention I've checked both "System setting > keyboard > Shortcuts" and compiz config manager and the shortcut key doesn't exist in either. – raven Mar 19 '18 at 11:55
  • These are the available short cuts cheatography.com/sapemeg/cheat-sheets/ubuntu-unity-16-04. In my desktop too. no action is preformed when i press ctrl + alt + b. – Aravind Mar 19 '18 at 12:52
  • what was the action on ctrl + alt + b previously. – Aravind Mar 19 '18 at 12:52
  • There never was any action assigned to this shortcut in Ubuntu. In Intellij it is supposed to navigate to the implementations of a method, but Intellij doesn't detect the combination since something else consumes it and since this combination does something on every text box in every window, my guess is its something Ubuntu related... – raven Mar 19 '18 at 13:07
  • As i checked. These are the place where you can declear custom shortcut. I think intellij shortcut got changed. I found this article helpful. This article explain how to reassign shortcut. jetbrains.com/help/idea/… – Aravind Mar 19 '18 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.