0

I'm using Dell PowerEdge R530 and trying to reinstall Ubuntu server 16.04 on this server.

What I had done to reinstall it is simple: Made an ubuntu USB using UUI, Booted with the USB, Followed the instructions for reinstallation of Ubuntu.

I had experienced that Ubuntu automatically configure all the things required for the system into sda, which in my case was corresponding to the install USB. So, just during the sequence where I had to select partition, and boot loader location, I pulled the USB off and replugged it after that moment.

But the only message after I finish installing and rebooting is "Booting from Hard drive C:", and it lasts forever.

I gathered some information what to do in this situation, the majority of answers are dealing with boot-manager to reinstall boot loader. The problem is I'm trying to install server version, which means the server install USB does not support "try Ubuntu", so that I can not use that terminal screen to type something or install new components.

I tried to fix it with the install USB menu "Rescue a broken system" but the system says "There was a problem reading data from the CD-ROM", and refuse any additional installation. I tried "install the GRUB boot loader on a hard disk" while executing "Rescue a broken system", but The error message says "Installation sep failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Install the GRUB boot loader on a hard disk."

Well in that mode, I can use "Execute a shell" menu, but only limited commands are available. Even such commands as apt-get, fdisk, chroot don't work in that system.

When I just install all the things without unplugging USB, I found out I should always plug USB to boot it. I tried to change the bootable device into my HDD, but that one didn't work as the device does not accept HDD as bootable one, and once I tried to make it as empty DOS partition(maybe I tried o option after fdisk) I could not boot sth.

  • I'm not using UEFI mode.
  • No other OSes are installed. Only Ubuntu 16.04 server.
  • GUI might not be working..because now I'm working on server edition.

I've been stuck on this problem for several days, and getting fed up with repeating reinstallation in front of the server.... Unlike the situation with desktop version there were not much information about server edition..

  • "So, just during the sequence where I had to select partition, and boot loader location, I pulled the USB off and replugged it after that moment." – Does that mean that you unplugged the installation medium during the installation? – David Foerster Mar 18 '18 at 12:39
0

I had same issue, Boot with live cd, run GPARTED Create >1MB unformatted partition with bios_grub flag, Than install and run boot-repair (or run grub-repair on boot partition) Reboot..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.