7

I have installed Ubuntu 16.04 on my new Alienware 17 R4 laptop that comes with Killer 1550 WiFi network card. Currently I am running on LAN cable to connect to the internet but would very much like to make use of my WiFi card. I have tested that it works well in Windows 10.

How do I get Killer 1550 installed on Alienware 17 R4?

The following are my outputs from sudo lshw -C network:

hello@world:~$ sudo lshw -C network

*-network
description: Ethernet interface
product: Qualcomm Atheros
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:3c:00.0
logical name: enp60s0
version: 10
serial: 10:65:30:fd:d6:35
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip=192.168.1.92 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:16 memory:dd300000-dd33ffff ioport:d000(size=128)

***-network UNCLAIMED
description: Network controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:3d:00.0
version: 29
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix cap_list
configuration: latency=0
resources: memory:dd200000-dd203fff**

I can certainly use my ethernet hence I believe I do have the Qualcomm Atheros driver. Probing further on my network controller (WiFi card?):

hello@world:~$ lspci -knn | grep Net -A2
3d:00.0 Network controller [0280]: Intel Corporation Device [8086:2526] (rev 29)
Subsystem: Bigfoot Networks, Inc. Device [1a56:1550]
3e:00.0 Non-Volatile memory controller [0108]: Toshiba America Info Systems Device [1179:0116]
Subsystem: Toshiba America Info Systems Device [1179:0001]

In case this could be of any useful information, my current linux kernel is:

hello@world:~$ uname -r
4.13.0-37-generic

Thank you all for reading and your kind assistance in getting my wifi to work!

P.S.: I tried suggestions found here Wifi not working in Ubuntu 16.04 LTS on an Alienware 17 R4 but it doesn't work for me.

  • Please edit to add result for lspci -nv -s 3d:00.0 – Jeremy31 Mar 20 '18 at 16:16
  • Thanks Jeremy, the output was as follows: hello@world:~$ lspci -nv -s 3d:00.0 3d:00.0 0280: 8086:2526 (rev 29) Subsystem: 1a56:1550 Flags: fast devsel, IRQ 255 Memory at dd200000 (64-bit, non-prefetchable) [disabled] [size=16K] Capabilities: <access denied> – Kenny Low Apr 2 '18 at 1:59
  • Tried this on Ubuntu 18.04 today and WiFi still does not work :/ – aikeru Apr 16 '18 at 17:18
  • I contacted killer networking last month and they said "Unfortunately, there is not currently a Linux driver or firmware for the 1550. We apologize for the inconvenience." "..since the 1550 is Intel-based, it's likely that it won't take too long." – Mygod Apr 23 '18 at 19:04
  • I hope they release a patch soon. Keep us updated! – Kenny Low Apr 25 '18 at 11:21
8

Intel recently added the VID and PID to their backports, to install

sudo apt-get install git
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
Reboot and if the wireless doesn't work, in terminal dmesg | grep iwl | nc termbin.com 9999 and post the URL from terminal in a comment as we made need to get firmware from upstream

After a kernel update you will need to

cd backport-iwlwifi
make clean
make defconfig-iwlwifi-public
make -j4
sudo make install

  • Searched for this for too long! Worked on kernel 4.15 for me too! Actually commenting here because I have internet :D – Fred Jul 16 '18 at 22:12
  • Good to hear Fred – Jeremy31 Jul 16 '18 at 22:38
  • Thank you Jeremy! It worked for me too, pardon for the long delay! – Kenny Low Sep 7 '18 at 6:37
  • Thank you so much! This worked for my MSI GS65 with Ubuntu 18.04 – T M Sep 15 '18 at 16:34
  • thanks for the post. was searching for this for a while. – Naseeruddin V N Sep 18 '18 at 15:51

protected by Community Mar 6 at 18:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.